# CVE-2025-49128: Jackson-core Vulnerable to Memory Disclosure via Source Snippet in JsonLocation

> Attackers can read up to 500 bytes of unintended memory content via JSON parsing exception messages in Jackson-core, potentially exposing sensitive data from reused buffers.

- **Severity:** Medium 4.0 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jun 2025
- **Updated:** 9 Jun 2025
- **Also known as:** CLEANSTART-2026-GA95827, CLEANSTART-2026-LD22950, CLEANSTART-2026-OC06333, DEBIAN-CVE-2025-49128, ECHO-ca28-4475-76f1, GHSA-wf8f-6423-gfxg, MINI-27gr-j8x3-c46x, MINI-68qh-2ph5-cgc6, MINI-76gf-8mfh-x7rp, MINI-7gfw-wmm3-xmcw, MINI-m367-2444-w8vj, MINI-mhr9-2m7m-526j, MINI-w3cc-64fc-qj3w, MINI-ww2f-c2gx-g4gv, RHLW-2026-bdf75f90d46c1da0, ROOT-APP-MAVEN-CVE-2025-49128, UBUNTU-CVE-2025-49128

## What is CVE-2025-49128?

CVE-2025-49128 is a medium-severity vulnerability in FasterXML jackson-core, published on 6 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Jackson-core contains core low-level incremental ("streaming") parser and generator abstractions used by Jackson Data Processor. Starting in version 2.0.0 and prior to version 2.13.0, a flaw in jackson-core's `JsonLocation._appendSourceDesc` method allows up to 500 bytes of unintended memory content to be included in exception messages. When parsing JSON from a byte array with an offset and length, the exception message incorrectly reads from the beginning of the array instead of the logical payload start. This results in possible information disclosure in systems using pooled or reused buffers, like Netty or Vert.x. This issue was silently fixed in jackson-core version 2.13.0, released on September 30, 2021, via PR #652. All users should upgrade to version 2.13.0 or later. If upgrading is not immediately possible, applications can mitigate the issue by disabling exception message exposure to clients to avoid returning parsing exception messages in HTTP responses and/or disabling source inclusion in exceptions to prevent Jackson from embedding any source content in exception messages, avoiding leakage.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2025-49128?

2 open source packages ship an affected version, including com.fasterxml.jackson.core:jackson-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.fasterxml.jackson.core:jackson-core` | Maven | From 2.0.0 | 2.13.0 |
| `com.fasterxml.jackson.core:jackson-core` | Maven | From 2.0.0 | 2.13.0 |

## How do I fix CVE-2025-49128?

Upgrade com.fasterxml.jackson.core:jackson-core to 2.13.0 or later.

## Is CVE-2025-49128 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49128 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49128 and fix it if it is affected.

What it is: CVE-2025-49128 is a medium-severity vulnerability in FasterXML jackson-core, published on 6 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49128 exists.

Affected packages and fixed versions:
- com.fasterxml.jackson.core:jackson-core (Maven): affected from 2.0.0; fixed in 2.13.0
- com.fasterxml.jackson.core:jackson-core (Maven): affected from 2.0.0; fixed in 2.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49128/ (Markdown: https://insights.sbomify.com/CVE-2025-49128/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49128
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49128
- OSV: https://osv.dev/vulnerability/CVE-2025-49128

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49128/
Summaries are generated and may contain mistakes; the official description above is the record.
