{"answers":{"affected":"2 open source packages ship an affected version, including barryvdh/laravel-translation-manager.","exploited":"There is no known exploitation of CVE-2025-49130 in the wild and no public exploit code.","fix":"Upgrade barryvdh/laravel-translation-manager to 0.6.8 or later.","what":"CVE-2025-49130 is a medium-severity cross-site scripting vulnerability in barryvdh laravel-translation-manager, published on 9 Jun 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-49130 and fix it if it is affected.\n\nWhat it is: CVE-2025-49130 is a medium-severity cross-site scripting vulnerability in barryvdh laravel-translation-manager, published on 9 Jun 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-49130 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- barryvdh/laravel-translation-manager (Packagist): affected all versions; fixed in 0.6.8\n- barryvdh/laravel-translation-manager (Packagist): affected all versions; fixed in 0.6.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-49130/ (Markdown: https://insights.sbomify.com/CVE-2025-49130/index.md)","id":"CVE-2025-49130","markdown":"https://insights.sbomify.com/CVE-2025-49130/index.md","name":"CVE-2025-49130","record":{"aliases":["GHSA-j226-63j7-qrqh"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Laravel translation package","requires_auth":"high_privilege","summary":"Authenticated users can inject malicious scripts into translation files, enabling session hijacking or data theft in Laravel applications.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Laravel Translation Manager is a package to manage Laravel translation files. Prior to version 0.6.8, the application is vulnerable to Cross-Site Scripting (XSS) attacks due to incorrect input validation and sanitization of user-input data. An attacker can inject arbitrary HTML code, including JavaScript scripts, into the page processed by the user's browser, allowing them to steal sensitive data, hijack user sessions, or conduct other malicious activities. Only authenticated users with access to the translation manager are impacted. The issue is fixed in version 0.6.8.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Laravel Translation Manager Vulnerable to Stored Cross-site Scripting","id":"CVE-2025-49130","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":4,"next":{"headline":"FastGPT Sandbox Vulnerable to Sandbox Bypass","id":"CVE-2025-49131"},"packages":[{"ecosystem":"Packagist","fixed":["0.6.8"],"introduced":["0"],"last_affected":[],"package":"barryvdh/laravel-translation-manager","purl":null,"source":"GHSA-j226-63j7-qrqh"},{"ecosystem":"Packagist","fixed":["0.6.8"],"introduced":["0"],"last_affected":[],"package":"barryvdh/laravel-translation-manager","purl":"pkg:composer/barryvdh/laravel-translation-manager","source":"GHSA-j226-63j7-qrqh"}],"prev":{"headline":"Jackson-core Vulnerable to Memory Disclosure via Source Snippet in JsonLocation","id":"CVE-2025-49128"},"products":["laravel-translation-manager"],"published":"2025-06-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-09","vendors":["barryvdh"]},"summary":"Authenticated users can inject malicious scripts into translation files, enabling session hijacking or data theft in Laravel applications.","url":"https://insights.sbomify.com/CVE-2025-49130/"}