# CVE-2025-49130: Laravel Translation Manager Vulnerable to Stored Cross-site Scripting

> Authenticated users can inject malicious scripts into translation files, enabling session hijacking or data theft in Laravel applications.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Jun 2025
- **Updated:** 9 Jun 2025
- **Also known as:** GHSA-j226-63j7-qrqh

## What is CVE-2025-49130?

CVE-2025-49130 is a medium-severity cross-site scripting vulnerability in barryvdh laravel-translation-manager, published on 9 Jun 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Laravel Translation Manager is a package to manage Laravel translation files. Prior to version 0.6.8, the application is vulnerable to Cross-Site Scripting (XSS) attacks due to incorrect input validation and sanitization of user-input data. An attacker can inject arbitrary HTML code, including JavaScript scripts, into the page processed by the user's browser, allowing them to steal sensitive data, hijack user sessions, or conduct other malicious activities. Only authenticated users with access to the translation manager are impacted. The issue is fixed in version 0.6.8.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-49130?

2 open source packages ship an affected version, including barryvdh/laravel-translation-manager.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `barryvdh/laravel-translation-manager` | Packagist | All versions | 0.6.8 |
| `barryvdh/laravel-translation-manager` | Packagist | All versions | 0.6.8 |

## How do I fix CVE-2025-49130?

Upgrade barryvdh/laravel-translation-manager to 0.6.8 or later.

## Is CVE-2025-49130 being exploited?

There is no known exploitation of CVE-2025-49130 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49130 and fix it if it is affected.

What it is: CVE-2025-49130 is a medium-severity cross-site scripting vulnerability in barryvdh laravel-translation-manager, published on 9 Jun 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-49130 in the wild and no public exploit code.

Affected packages and fixed versions:
- barryvdh/laravel-translation-manager (Packagist): affected all versions; fixed in 0.6.8
- barryvdh/laravel-translation-manager (Packagist): affected all versions; fixed in 0.6.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49130/ (Markdown: https://insights.sbomify.com/CVE-2025-49130/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49130
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49130
- OSV: https://osv.dev/vulnerability/CVE-2025-49130

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49130/
Summaries are generated and may contain mistakes; the official description above is the record.
