{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49131 exists.","fix":"No fix has been published for CVE-2025-49131 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-49131 is a medium-severity vulnerability in labring FastGPT, published on 9 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-49131 and fix it if it is affected.\n\nWhat it is: CVE-2025-49131 is a medium-severity vulnerability in labring FastGPT, published on 9 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49131 exists.\n\nAffected product: labring FastGPT. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-49131/ (Markdown: https://insights.sbomify.com/CVE-2025-49131/index.md)","id":"CVE-2025-49131","markdown":"https://insights.sbomify.com/CVE-2025-49131/index.md","name":"CVE-2025-49131","record":{"aliases":["GHSA-f3pf-r3g7-g895"],"analysis":{"component_type":"container_or_infrastructure","fix_type":"upgrade","impacts":["code_execution","data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"AI workflow sandbox","requires_auth":"low_privilege","summary":"Attackers can escape the FastGPT sandbox to execute arbitrary code and read or modify files due to insufficient syscall restrictions.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fastgpt","vendor":"fastgpt"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-732","name":"Incorrect Permission Assignment for Critical Resource"}],"description":"FastGPT is an open-source project that provides a platform for building, deploying, and operating AI-driven workflows and conversational agents. The Sandbox container (fastgpt-sandbox) is a specialized, isolated environment used by FastGPT to safely execute user-submitted or dynamically generated code in isolation. The sandbox before version 4.9.11 has insufficient isolation and inadequate restrictions on code execution by allowing overly permissive syscalls, which allows attackers to escape the intended sandbox boundaries. Attackers could exploit this to read and overwrite arbitrary files and bypass Python module import restrictions. This is patched in version 4.9.11 by restricting the allowed system calls to a safer subset and additional descriptive error messaging.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":"2025-12-30","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-12-30T04:30:57Z","kind":"github_poc","ref":"https://github.com/Wenura17125/cve-2025-49131-poc","stars":0,"title":null}],"tier":"weaponised"},"has_fix":false,"headline":"FastGPT Sandbox Vulnerable to Sandbox Bypass","id":"CVE-2025-49131","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"security_feature_bypass","year":"2025"},"n_packages":0,"n_references":5,"next":{"headline":"Pterodactyl Panel Allows Unauthenticated Arbitrary Remote Code Execution","id":"CVE-2025-49132"},"packages":[],"prev":{"headline":"Laravel Translation Manager Vulnerable to Stored Cross-site Scripting","id":"CVE-2025-49130"},"products":["FastGPT"],"published":"2025-06-09","related":[{"cvss_score":10,"headline":"FastGPT: Unauthenticated SSRF via httpTools Endpoint Leads to Internal API Key Theft","id":"CVE-2026-34162","kev_date_added":null,"published":"2026-03-31"},{"cvss_score":9.8,"headline":"FastGPT: NoSQL Injection in loginByPassword leads to Authentication Bypass","id":"CVE-2026-40351","kev_date_added":null,"published":"2026-04-17"},{"cvss_score":9.4,"headline":"FastGPT has Arbitrary Code Execution in GitHub Actions via pull_request_target in fastgpt-preview-image.yml","id":"CVE-2026-33075","kev_date_added":null,"published":"2026-03-20"},{"cvss_score":8.8,"headline":"FastGPT: NoSQL Injection in updatePasswordByOld Leads to Account Takeover","id":"CVE-2026-40352","kev_date_added":null,"published":"2026-04-17"},{"cvss_score":7.7,"headline":"Server-Side Request Forgery via MCP Tools Endpoint in FastGPT","id":"CVE-2026-34163","kev_date_added":null,"published":"2026-03-31"},{"cvss_score":6.9,"headline":"Cross-Site Request Forgery (CSRF) in FastGPT","id":"CVE-2026-26075","kev_date_added":null,"published":"2026-02-12"},{"cvss_score":6.9,"headline":"FastGPT Plugin forwarding request is not authenticated, posing a serious risk of attack","id":"CVE-2026-26003","kev_date_added":null,"published":"2026-02-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-09","vendors":["labring"]},"summary":"Attackers can escape the FastGPT sandbox to execute arbitrary code and read or modify files due to insufficient syscall restrictions.","url":"https://insights.sbomify.com/CVE-2025-49131/"}