# CVE-2025-49131: FastGPT Sandbox Vulnerable to Sandbox Bypass

> Attackers can escape the FastGPT sandbox to execute arbitrary code and read or modify files due to insufficient syscall restrictions.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Jun 2025
- **Updated:** 9 Jun 2025
- **Also known as:** GHSA-f3pf-r3g7-g895

## What is CVE-2025-49131?

CVE-2025-49131 is a medium-severity vulnerability in labring FastGPT, published on 9 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

FastGPT is an open-source project that provides a platform for building, deploying, and operating AI-driven workflows and conversational agents. The Sandbox container (fastgpt-sandbox) is a specialized, isolated environment used by FastGPT to safely execute user-submitted or dynamically generated code in isolation. The sandbox before version 4.9.11 has insufficient isolation and inadequate restrictions on code execution by allowing overly permissive syscalls, which allows attackers to escape the intended sandbox boundaries. Attackers could exploit this to read and overwrite arbitrary files and bypass Python module import restrictions. This is patched in version 4.9.11 by restricting the allowed system calls to a safer subset and additional descriptive error messaging.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2025-49131?

It affects 1 product.


Products: Fastgpt Fastgpt.

## How do I fix CVE-2025-49131?

No fix has been published for CVE-2025-49131 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-49131 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49131 exists.

Public exploit code:

- https://github.com/Wenura17125/cve-2025-49131-poc (github_poc): https://github.com/Wenura17125/cve-2025-49131-poc

## Other vulnerabilities in labring FastGPT

- [CVE-2026-34162](https://insights.sbomify.com/CVE-2026-34162/): FastGPT: Unauthenticated SSRF via httpTools Endpoint Leads to Internal API Key Theft (critical 10.0)
- [CVE-2026-40351](https://insights.sbomify.com/CVE-2026-40351/): FastGPT: NoSQL Injection in loginByPassword leads to Authentication Bypass (critical 9.8)
- [CVE-2026-33075](https://insights.sbomify.com/CVE-2026-33075/): FastGPT has Arbitrary Code Execution in GitHub Actions via pull_request_target in fastgpt-preview-image.yml (critical 9.4)
- [CVE-2026-40352](https://insights.sbomify.com/CVE-2026-40352/): FastGPT: NoSQL Injection in updatePasswordByOld Leads to Account Takeover (high 8.8)
- [CVE-2026-34163](https://insights.sbomify.com/CVE-2026-34163/): Server-Side Request Forgery via MCP Tools Endpoint in FastGPT (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49131 and fix it if it is affected.

What it is: CVE-2025-49131 is a medium-severity vulnerability in labring FastGPT, published on 9 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49131 exists.

Affected product: labring FastGPT. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49131/ (Markdown: https://insights.sbomify.com/CVE-2025-49131/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49131
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49131
- OSV: https://osv.dev/vulnerability/CVE-2025-49131

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49131/
Summaries are generated and may contain mistakes; the official description above is the record.
