# CVE-2025-49132: Pterodactyl Panel Allows Unauthenticated Arbitrary Remote Code Execution

> Unauthenticated attackers can execute arbitrary code via the locale endpoint, leading to full server compromise and data theft.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jun 2025
- **Updated:** 20 Jun 2025
- **Also known as:** GHSA-24wv-6c99-f843

## What is CVE-2025-49132?

CVE-2025-49132 is a critical code injection vulnerability in pterodactyl panel, published on 20 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pterodactyl is a free, open-source game server management panel. Prior to version 1.11.11, using the /locales/locale.json with the locale and namespace query parameters, a malicious actor is able to execute arbitrary code without being authenticated. With the ability to execute arbitrary code it could be used to gain access to the Panel's server, read credentials from the Panel's config, extract sensitive information from the database, access files of servers managed by the panel, etc. This issue has been patched in version 1.11.11. There are no software workarounds for this vulnerability, but use of an external Web Application Firewall (WAF) could help mitigate this attack.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2025-49132?

2 open source packages ship an affected version, including pterodactyl/panel.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pterodactyl/panel` | Packagist | All versions | 1.11.11 |
| `pterodactyl/panel` | Packagist | All versions | 1.11.11 |

## How do I fix CVE-2025-49132?

Upgrade pterodactyl/panel to 1.11.11 or later.

## Is CVE-2025-49132 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49132 exists.

Public exploit code:

- Exploit for Pterodactyl Panel ≤ 1.11.10 - unauthenticated LFI to RCE. (github_poc): https://github.com/YoyoChaud/CVE-2025-49132
- A script that gives you the credentials of a Pterodactyl panel vulnerable to CVE-2025-49132 (github_poc): https://github.com/Zen-kun04/CVE-2025-49132
- https://github.com/malw0re/CVE-2025-49132-Mods (github_poc): https://github.com/malw0re/CVE-2025-49132-Mods
- PoCs for CVE-2025-49132 (github_poc): https://github.com/63square/CVE-2025-49132
- Pterodactyl翼龙面板CVE-2025-49132批量检测☝️🤓 (github_poc): https://github.com/qiaojojo/CVE-2025-49132_poc
- This repository contains a Proof of Concept (PoC) for CVE-2025-49132, a critical vulnerability in Pterodactyl Panel versions < 1.11.11. (github_poc): https://github.com/str1keboo/CVE-2025-49132

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49132 and fix it if it is affected.

What it is: CVE-2025-49132 is a critical code injection vulnerability in pterodactyl panel, published on 20 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49132 exists.

Affected packages and fixed versions:
- pterodactyl/panel (Packagist): affected all versions; fixed in 1.11.11
- pterodactyl/panel (Packagist): affected all versions; fixed in 1.11.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49132/ (Markdown: https://insights.sbomify.com/CVE-2025-49132/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49132
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49132
- OSV: https://osv.dev/vulnerability/CVE-2025-49132

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49132/
Summaries are generated and may contain mistakes; the official description above is the record.
