# CVE-2025-49137: Hax CMS Stored Cross-Site Scripting vulnerability

> Attackers can inject arbitrary JavaScript via unsanitized input in Hax CMS, leading to potential session hijacking or site defacement.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jun 2025
- **Updated:** 10 Jun 2025
- **Also known as:** GHSA-2vc4-3hx7-v7v7

## What is CVE-2025-49137?

CVE-2025-49137 is a high-severity cross-site scripting vulnerability in haxtheweb issues, published on 9 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

HAX CMS PHP allows users to manage their microsite universe with a PHP backend. Prior to version 11.0.0, the application does not sufficiently sanitize user input, allowing for the execution of arbitrary JavaScript code. The 'saveNode' and 'saveManifest' endpoints take user input and store it in the JSON schema for the site. This content is then rendered in the generated HAX site. Although the application does not allow users to supply a `script` tag, it does allow the use of other HTML tags to run JavaScript. Version 11.0.0 fixes the issue.

Weakness: CWE-87 (Improper Neutralization of Alternate XSS Syntax), CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-49137?

2 open source packages ship an affected version, including elmsln/haxcms. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `elmsln/haxcms` | Packagist | All versions | 11.0.0 |
| `elmsln/haxcms` | Packagist | All versions | 11.0.0 |

Products: Psu Haxcms-Nodejs, Psu Haxcms-Php.

## How do I fix CVE-2025-49137?

Upgrade elmsln/haxcms to 11.0.0 or later.

## Is CVE-2025-49137 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49137 exists.

## Other vulnerabilities in haxtheweb issues

- [CVE-2025-54127](https://insights.sbomify.com/CVE-2025-54127/): HAXcms's Insecure Default Configuration Leads to Unauthenticated Access (critical 9.3)
- [CVE-2025-49141](https://insights.sbomify.com/CVE-2025-49141/): HaxCMS-PHP Command Injection Vulnerability (high 8.6)
- [CVE-2025-54378](https://insights.sbomify.com/CVE-2025-54378/): HAX CMS Backend Lacks Comprehensive Authorization Checks (high 8.3)
- [CVE-2026-22704](https://insights.sbomify.com/CVE-2026-22704/): HAXcms Has Stored XSS Vulnerability that May Lead to Account Takeover (high 8.1)
- [CVE-2025-54137](https://insights.sbomify.com/CVE-2025-54137/): NodeJS version of the HAX CMS application is distributed with Default Secrets (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49137 and fix it if it is affected.

What it is: CVE-2025-49137 is a high-severity cross-site scripting vulnerability in haxtheweb issues, published on 9 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49137 exists.

Affected packages and fixed versions:
- elmsln/haxcms (Packagist): affected all versions; fixed in 11.0.0
- elmsln/haxcms (Packagist): affected all versions; fixed in 11.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49137/ (Markdown: https://insights.sbomify.com/CVE-2025-49137/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49137
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49137
- OSV: https://osv.dev/vulnerability/CVE-2025-49137

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49137/
Summaries are generated and may contain mistakes; the official description above is the record.
