{"answers":{"affected":"2 open source packages ship an affected version, including elmsln/haxcms. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49138 exists.","fix":"Upgrade elmsln/haxcms to 11.0.0 or later.","what":"CVE-2025-49138 is a medium-severity path traversal vulnerability in haxtheweb issues, published on 9 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-49138 and fix it if it is affected.\n\nWhat it is: CVE-2025-49138 is a medium-severity path traversal vulnerability in haxtheweb issues, published on 9 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49138 exists.\n\nAffected packages and fixed versions:\n- elmsln/haxcms (Packagist): affected all versions; fixed in 11.0.0\n- elmsln/haxcms (Packagist): affected all versions; fixed in 11.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-49138/ (Markdown: https://insights.sbomify.com/CVE-2025-49138/index.md)","id":"CVE-2025-49138","markdown":"https://insights.sbomify.com/CVE-2025-49138/index.md","name":"CVE-2025-49138","record":{"aliases":["GHSA-hxrr-x32w-cg8g"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"HAX CMS","requires_auth":"low_privilege","summary":"An authenticated low-privileged user can read arbitrary server files via Local File Inclusion in the saveOutline API.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"haxcms-php","vendor":"psu"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-73","name":"External Control of File Name or Path"},{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"HAX CMS PHP allows users to manage their microsite universe with a PHP backend. Prior to version 11.0.0, an authenticated Local File Inclusion (LFI) vulnerability in the HAXCMS saveOutline endpoint allows a low-privileged user to read arbitrary files on the server by manipulating the location field written into site.json. This enables attackers to exfiltrate sensitive system files such as /etc/passwd, application secrets, or configuration files accessible to the web server (www-data). The vulnerability stems from the way the HAXCMS backend handles the location field in the site's outline. When a user sends a POST request to /system/api/saveOutline, the backend stores the provided location value directly into the site.json file associated with the site, without validating or sanitizing the input. Later the location parameter is interpreted by the CMS to resolve and load the content for a given node. If the location field contains a relative path like `../../../etc/passwd`, the application will attempt to read and render that file. Version 11.0.0 fixes the issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"HAX CMS vulnerable to Local File Inclusion via saveOutline API Location Parameter","id":"CVE-2025-49138","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"path_traversal","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"@haxtheweb/haxcms-nodejs Iframe Phishing vulnerability","id":"CVE-2025-49139"},"packages":[{"ecosystem":"Packagist","fixed":["11.0.0"],"introduced":["0"],"last_affected":[],"package":"elmsln/haxcms","purl":null,"source":"GHSA-hxrr-x32w-cg8g"},{"ecosystem":"Packagist","fixed":["11.0.0"],"introduced":["0"],"last_affected":[],"package":"elmsln/haxcms","purl":"pkg:composer/elmsln/haxcms","source":"GHSA-hxrr-x32w-cg8g"}],"prev":{"headline":"Hax CMS Stored Cross-Site Scripting vulnerability","id":"CVE-2025-49137"},"products":["issues"],"published":"2025-06-09","related":[{"cvss_score":10,"headline":"HAX CMS PHP allows Insecure File Upload to Lead to Remote Code Execution","id":"CVE-2025-32028","kev_date_added":null,"published":"2025-04-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-10","vendors":["haxtheweb"]},"summary":"An authenticated low-privileged user can read arbitrary server files via Local File Inclusion in the saveOutline API.","url":"https://insights.sbomify.com/CVE-2025-49138/"}