# CVE-2025-49139: @haxtheweb/haxcms-nodejs Iframe Phishing vulnerability

> An authenticated attacker can create a malicious site with an iframe to phish credentials from other users visiting the site.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Jun 2025
- **Updated:** 10 Jun 2025
- **Also known as:** GHSA-v3ph-2q5q-cg88

## What is CVE-2025-49139?

CVE-2025-49139 is a medium-severity vulnerability in haxtheweb issues, published on 9 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

HAX CMS PHP allows users to manage their microsite universe with a PHP backend. Prior to version 11.0.0, in the HAX site editor, users can create a website block to load another site in an iframe. The application allows users to supply a target URL in the website block. When the HAX site is visited, the client's browser will query the supplied URL. An authenticated attacker can create a HAX site with a website block pointing at an attacker-controlled server running Responder or a similar tool. The attacker can then conduct a phishing attack by convincing another user to visit their malicious HAX site to harvest credentials. Version 11.0.0 contains a patch for the issue.

Weakness: CWE-1021 (Improper Restriction of Rendered UI Layers or Frames)

## Which versions are affected by CVE-2025-49139?

2 open source packages ship an affected version, including @haxtheweb/haxcms-nodejs. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@haxtheweb/haxcms-nodejs` | npm | All versions | 11.0.0 |
| `@haxtheweb/haxcms-nodejs` | npm | All versions | 11.0.0 |

Products: Psu Haxcms-Nodejs, Psu Haxcms-Php.

## How do I fix CVE-2025-49139?

Upgrade @haxtheweb/haxcms-nodejs to 11.0.0 or later.

## Is CVE-2025-49139 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49139 exists.

## Other vulnerabilities in haxtheweb issues

- [CVE-2025-54127](https://insights.sbomify.com/CVE-2025-54127/): HAXcms's Insecure Default Configuration Leads to Unauthenticated Access (critical 9.3)
- [CVE-2025-49141](https://insights.sbomify.com/CVE-2025-49141/): HaxCMS-PHP Command Injection Vulnerability (high 8.6)
- [CVE-2025-49137](https://insights.sbomify.com/CVE-2025-49137/): Hax CMS Stored Cross-Site Scripting vulnerability (high 8.5)
- [CVE-2025-54378](https://insights.sbomify.com/CVE-2025-54378/): HAX CMS Backend Lacks Comprehensive Authorization Checks (high 8.3)
- [CVE-2026-22704](https://insights.sbomify.com/CVE-2026-22704/): HAXcms Has Stored XSS Vulnerability that May Lead to Account Takeover (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49139 and fix it if it is affected.

What it is: CVE-2025-49139 is a medium-severity vulnerability in haxtheweb issues, published on 9 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49139 exists.

Affected packages and fixed versions:
- @haxtheweb/haxcms-nodejs (npm): affected all versions; fixed in 11.0.0
- @haxtheweb/haxcms-nodejs (npm): affected all versions; fixed in 11.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49139/ (Markdown: https://insights.sbomify.com/CVE-2025-49139/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49139
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49139
- OSV: https://osv.dev/vulnerability/CVE-2025-49139

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49139/
Summaries are generated and may contain mistakes; the official description above is the record.
