{"answers":{"affected":"3 open source packages ship an affected version, including github.com/pion/interceptor.","exploited":"There is no known exploitation of CVE-2025-49140 in the wild and no public exploit code.","fix":"Upgrade github.com/pion/interceptor to 0.1.39 or later.","what":"CVE-2025-49140 is a high-severity denial of service vulnerability in pion interceptor, published on 9 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-49140 and fix it if it is affected.\n\nWhat it is: CVE-2025-49140 is a high-severity denial of service vulnerability in pion interceptor, published on 9 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-49140 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/pion/interceptor (Go): affected from 0.1.36; fixed in 0.1.39\n- github.com/pion/interceptor (Go): affected from 0.1.36; fixed in 0.1.39\n- github.com/pion/interceptor (Go): affected from 0.1.36; fixed in 0.1.39\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-49140/ (Markdown: https://insights.sbomify.com/CVE-2025-49140/index.md)","id":"CVE-2025-49140","markdown":"https://insights.sbomify.com/CVE-2025-49140/index.md","name":"CVE-2025-49140","record":{"aliases":["GHSA-f26w-gh5m-qq77","GO-2025-3748","UBUNTU-CVE-2025-49140"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Go RTP interceptor library","requires_auth":"none","summary":"Remote attackers can crash Pion-based SFU applications by sending crafted RTP packets, requiring users to upgrade the interceptor library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"Pion Interceptor is a framework for building RTP/RTCP communication software. Versions v0.1.36 through v0.1.38 contain a bug in a RTP packet factory that can be exploited to trigger a panic with Pion based SFU via crafted RTP packets, This only affect users that use pion/interceptor. Users should upgrade to v0.1.39 or later, which validates that: `padLen \u003e 0 \u0026\u0026 padLen \u003c= payloadLength` and return error  on overflow, avoiding panic. If upgrading is not possible, apply the patch from the pull request manually or drop packets whose P-bit is set but whose padLen is zero or larger than the remaining payload.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Pion Interceptor's improper RTP padding handling allows remote crash for SFU users (DoS)","id":"CVE-2025-49140","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":3,"n_references":4,"next":{"headline":"HaxCMS-PHP Command Injection Vulnerability","id":"CVE-2025-49141"},"packages":[{"ecosystem":"Go","fixed":["0.1.39"],"introduced":["0.1.36"],"last_affected":[],"package":"github.com/pion/interceptor","purl":null,"source":"GHSA-f26w-gh5m-qq77"},{"ecosystem":"Go","fixed":["0.1.39"],"introduced":["0.1.36"],"last_affected":[],"package":"github.com/pion/interceptor","purl":"pkg:golang/github.com/pion/interceptor","source":"GHSA-f26w-gh5m-qq77"},{"ecosystem":"Go","fixed":["0.1.39"],"introduced":["0.1.36"],"last_affected":[],"package":"github.com/pion/interceptor","purl":"pkg:golang/github.com/pion/interceptor","source":"GO-2025-3748"}],"prev":{"headline":"@haxtheweb/haxcms-nodejs Iframe Phishing vulnerability","id":"CVE-2025-49139"},"products":["interceptor"],"published":"2025-06-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-10","vendors":["pion"]},"summary":"Remote attackers can crash Pion-based SFU applications by sending crafted RTP packets, requiring users to upgrade the interceptor library.","url":"https://insights.sbomify.com/CVE-2025-49140/"}