# CVE-2025-49140: Pion Interceptor's improper RTP padding handling allows remote crash for SFU users (DoS)

> Remote attackers can crash Pion-based SFU applications by sending crafted RTP packets, requiring users to upgrade the interceptor library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jun 2025
- **Updated:** 10 Jun 2025
- **Also known as:** GHSA-f26w-gh5m-qq77, GO-2025-3748, UBUNTU-CVE-2025-49140

## What is CVE-2025-49140?

CVE-2025-49140 is a high-severity denial of service vulnerability in pion interceptor, published on 9 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pion Interceptor is a framework for building RTP/RTCP communication software. Versions v0.1.36 through v0.1.38 contain a bug in a RTP packet factory that can be exploited to trigger a panic with Pion based SFU via crafted RTP packets, This only affect users that use pion/interceptor. Users should upgrade to v0.1.39 or later, which validates that: `padLen > 0 && padLen <= payloadLength` and return error  on overflow, avoiding panic. If upgrading is not possible, apply the patch from the pull request manually or drop packets whose P-bit is set but whose padLen is zero or larger than the remaining payload.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-49140?

3 open source packages ship an affected version, including github.com/pion/interceptor.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/pion/interceptor` | Go | From 0.1.36 | 0.1.39 |
| `github.com/pion/interceptor` | Go | From 0.1.36 | 0.1.39 |
| `github.com/pion/interceptor` | Go | From 0.1.36 | 0.1.39 |

## How do I fix CVE-2025-49140?

Upgrade github.com/pion/interceptor to 0.1.39 or later.

## Is CVE-2025-49140 being exploited?

There is no known exploitation of CVE-2025-49140 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49140 and fix it if it is affected.

What it is: CVE-2025-49140 is a high-severity denial of service vulnerability in pion interceptor, published on 9 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-49140 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/pion/interceptor (Go): affected from 0.1.36; fixed in 0.1.39
- github.com/pion/interceptor (Go): affected from 0.1.36; fixed in 0.1.39
- github.com/pion/interceptor (Go): affected from 0.1.36; fixed in 0.1.39

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49140/ (Markdown: https://insights.sbomify.com/CVE-2025-49140/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49140
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49140
- OSV: https://osv.dev/vulnerability/CVE-2025-49140

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49140/
Summaries are generated and may contain mistakes; the official description above is the record.
