# CVE-2025-49142: Nautobot vulnerable to secrets exposure and data manipulation through Jinja2 templating

> Malicious users can exploit Jinja2 templating to expose secrets and modify data, bypassing permission controls in Nautobot.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:L/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2025
- **Updated:** 10 Jun 2025
- **Also known as:** GHSA-wjw6-95h5-4jpx, PYSEC-2025-79

## What is CVE-2025-49142?

CVE-2025-49142 is a medium-severity code injection vulnerability in nautobot, published on 10 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Nautobot is a Network Source of Truth and Network Automation Platform. All users of Nautobot versions prior to 2.4.10 or prior to 1.6.32 are potentially affected. Due to insufficient security configuration of the Jinja2 templating feature used in computed fields, custom links, etc. in Nautobot, a malicious user could configure this feature set in ways that could expose the value of Secrets defined in Nautobot when the templated content is rendered or that could call Python APIs to modify data within Nautobot when the templated content is rendered, bypassing the object permissions assigned to the viewing user. Nautobot versions 1.6.32 and 2.4.10 will include fixes for the vulnerability. The vulnerability can be partially mitigated by configuring object permissions appropriately to limit certain actions to only trusted users.

Weakness: CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2025-49142?

5 open source packages ship an affected version, including nautobot. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nautobot` | PyPI | All versions | 1.6.32, 2.4.10 |
| `nautobot` | PyPI | All versions | 1.6.32 |
| `nautobot` | PyPI | All versions | 1.6.32 |
| `nautobot` | PyPI | From 2.0.0 | 2.4.10 |
| `nautobot` | PyPI | From 2.0.0 | 2.4.10 |

Products: Networktocode Nautobot.

## How do I fix CVE-2025-49142?

Upgrade nautobot to a fixed version for your release line: 1.6.32 or 2.4.10.

## Is CVE-2025-49142 being exploited?

There is no known exploitation of CVE-2025-49142 in the wild and no public exploit code.

## Other vulnerabilities in nautobot

- [CVE-2026-44797](https://insights.sbomify.com/CVE-2026-44797/): Nautobot: Webhook definitions could be used for server-side request forgery (SSRF) (high 8.5)
- [CVE-2024-34707](https://insights.sbomify.com/CVE-2024-34707/): Nautobot's BANNER_* configuration can be used to inject arbitrary HTML content into Nautobot pages (high 7.5)
- [CVE-2024-32979](https://insights.sbomify.com/CVE-2024-32979/): Reflected Cross-site Scripting potential in all object list views in Nautobot (high 7.5)
- [CVE-2023-25657](https://insights.sbomify.com/CVE-2023-25657/): Remote code execution in Jinja2 template rendering in Nautobot (high 7.5)
- [CVE-2026-44798](https://insights.sbomify.com/CVE-2026-44798/): Nautobot: GitRepository.current_head field should not be writable through REST API (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49142 and fix it if it is affected.

What it is: CVE-2025-49142 is a medium-severity code injection vulnerability in nautobot, published on 10 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-49142 in the wild and no public exploit code.

Affected packages and fixed versions:
- nautobot (PyPI): affected all versions; fixed in 1.6.32, 2.4.10
- nautobot (PyPI): affected all versions; fixed in 1.6.32
- nautobot (PyPI): affected all versions; fixed in 1.6.32
- nautobot (PyPI): affected from 2.0.0; fixed in 2.4.10
- nautobot (PyPI): affected from 2.0.0; fixed in 2.4.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49142/ (Markdown: https://insights.sbomify.com/CVE-2025-49142/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49142
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49142
- OSV: https://osv.dev/vulnerability/CVE-2025-49142

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49142/
Summaries are generated and may contain mistakes; the official description above is the record.
