# CVE-2025-49143: Nautobot may allows uploaded media files to be accessible without authentication

> Attackers can access uploaded media files without authentication if they know the URL, exposing sensitive network device images and attachments.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2025
- **Updated:** 10 Jun 2025
- **Also known as:** GHSA-rh67-4c8j-hjjh, PYSEC-2026-1689

## What is CVE-2025-49143?

CVE-2025-49143 is a medium-severity missing authorization vulnerability in nautobot, published on 10 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Nautobot is a Network Source of Truth and Network Automation Platform. Prior to v2.4.10 and v1.6.32 , files uploaded by users to Nautobot's MEDIA_ROOT directory, including DeviceType image attachments as well as images attached to a Location, Device, or Rack, are served to users via a URL endpoint that was not enforcing user authentication. As a consequence, such files can be retrieved by anonymous users who know or can guess the correct URL for a given file. Nautobot v2.4.10 and v1.6.32 address this issue by adding enforcement of Nautobot user authentication to this endpoint.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-49143?

5 open source packages ship an affected version, including nautobot. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nautobot` | PyPI | All versions | 1.6.32, 2.4.10 |
| `nautobot` | PyPI | All versions | 1.6.32 |
| `nautobot` | PyPI | All versions | 1.6.32 |
| `nautobot` | PyPI | From 2.0.0 | 2.4.10 |
| `nautobot` | PyPI | From 2.0.0 | 2.4.10 |

Products: Networktocode Nautobot.

## How do I fix CVE-2025-49143?

Upgrade nautobot to a fixed version for your release line: 1.6.32 or 2.4.10.

## Is CVE-2025-49143 being exploited?

There is no known exploitation of CVE-2025-49143 in the wild and no public exploit code.

## Other vulnerabilities in nautobot

- [CVE-2026-44797](https://insights.sbomify.com/CVE-2026-44797/): Nautobot: Webhook definitions could be used for server-side request forgery (SSRF) (high 8.5)
- [CVE-2024-34707](https://insights.sbomify.com/CVE-2024-34707/): Nautobot's BANNER_* configuration can be used to inject arbitrary HTML content into Nautobot pages (high 7.5)
- [CVE-2024-32979](https://insights.sbomify.com/CVE-2024-32979/): Reflected Cross-site Scripting potential in all object list views in Nautobot (high 7.5)
- [CVE-2023-25657](https://insights.sbomify.com/CVE-2023-25657/): Remote code execution in Jinja2 template rendering in Nautobot (high 7.5)
- [CVE-2026-44798](https://insights.sbomify.com/CVE-2026-44798/): Nautobot: GitRepository.current_head field should not be writable through REST API (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49143 and fix it if it is affected.

What it is: CVE-2025-49143 is a medium-severity missing authorization vulnerability in nautobot, published on 10 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-49143 in the wild and no public exploit code.

Affected packages and fixed versions:
- nautobot (PyPI): affected all versions; fixed in 1.6.32, 2.4.10
- nautobot (PyPI): affected all versions; fixed in 1.6.32
- nautobot (PyPI): affected all versions; fixed in 1.6.32
- nautobot (PyPI): affected from 2.0.0; fixed in 2.4.10
- nautobot (PyPI): affected from 2.0.0; fixed in 2.4.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49143/ (Markdown: https://insights.sbomify.com/CVE-2025-49143/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49143
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49143
- OSV: https://osv.dev/vulnerability/CVE-2025-49143

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49143/
Summaries are generated and may contain mistakes; the official description above is the record.
