CVE-2025-49144 Notepad++ Privilege Escalation in Installer via Uncontrolled Executable Search Path

High 7.3 Published Updated

Unprivileged users can gain SYSTEM privileges by tricking victims into running the Notepad++ installer from a directory containing a malicious executable.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2025-49144?

CVE-2025-49144 is a high-severity vulnerability in notepad-plus-plus, published on 23 Jun 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

Notepad++ is a free and open-source source code editor. In versions 8.8.1 and prior, a privilege escalation vulnerability exists in the Notepad++ v8.8.1 installer that allows unprivileged users to gain SYSTEM-level privileges through insecure executable search paths. An attacker could use social engineering or clickjacking to trick users into downloading both the legitimate installer and a malicious executable to the same directory (typically Downloads folder - which is known as Vulnerable directory). Upon running the installer, the attack executes automatically with SYSTEM privileges. This issue has been fixed and will be released in version 8.8.2.

Weakness: CWE-427, CWE-276, CWE-272

Which versions are affected by CVE-2025-49144?

How do I fix CVE-2025-49144?

No fix has been published for CVE-2025-49144 yet. Limit exposure of the affected software until one is available.

Is CVE-2025-49144 being exploited?

There is no known exploitation of CVE-2025-49144 in the wild and no public exploit code.

Public exploit code: 8 proofs of concept on GitHub.

Sources

Also known as GHSA-9vx8-v79m-6m24.

Is CVE-2025-49144 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free