{"answers":{"affected":"3 open source packages ship an affected version, including org.postgresql:postgresql and postgresql-jdbc-driver. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-49146 in the wild and no public exploit code.","fix":"Upgrade org.postgresql:postgresql to 42.7.7 or later.","what":"CVE-2025-49146 is a high-severity vulnerability in pgjdbc, published on 11 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-49146 and fix it if it is affected.\n\nWhat it is: CVE-2025-49146 is a high-severity vulnerability in pgjdbc, published on 11 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-49146 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.postgresql:postgresql (Maven): affected from 42.7.4; fixed in 42.7.7\n- org.postgresql:postgresql (Maven): affected from 42.7.4; fixed in 42.7.7\n- postgresql-jdbc-driver (Bitnami): affected from 42.7.4; fixed in 42.7.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-49146/ (Markdown: https://insights.sbomify.com/CVE-2025-49146/index.md)","id":"CVE-2025-49146","markdown":"https://insights.sbomify.com/CVE-2025-49146/index.md","name":"CVE-2025-49146","record":{"aliases":["BIT-postgresql-jdbc-driver-2025-49146","CLEANSTART-2026-XL50889","CLEANSTART-2026-XW89737","DEBIAN-CVE-2025-49146","GHSA-hq9p-pm7w-8p54","MINI-g73j-m8fr-9j3r","ROOT-APP-MAVEN-CVE-2025-49146","UBUNTU-CVE-2025-49146","openSUSE-SU-2025:15264-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"PostgreSQL JDBC driver","requires_auth":"none","summary":"Attackers can bypass channel binding requirements in the PostgreSQL JDBC driver, enabling man-in-the-middle attacks on secure connections.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"postgresql_jdbc_driver","vendor":"postgresql"}],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"pgjdbc is an open source postgresql JDBC Driver. From 42.7.4 and until 42.7.7, when the PostgreSQL JDBC driver is configured with channel binding set to required (default value is prefer), the driver would incorrectly allow connections to proceed with authentication methods that do not support channel binding (such as password, MD5, GSS, or SSPI authentication). This could allow a man-in-the-middle attacker to intercept connections that users believed were protected by channel binding requirements. This vulnerability is fixed in 42.7.7.","ecosystems":["Bitnami","Maven","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"pgjdbc Client Allows Fallback to Insecure Authentication Despite channelBinding=require Configuration","id":"CVE-2025-49146","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"security_feature_bypass","year":"2025"},"n_packages":4,"n_references":2,"next":{"headline":"Umbraco.Cms Vulnerable to Disclosure of Configured Password Requirements","id":"CVE-2025-49147"},"packages":[{"ecosystem":"Bitnami","fixed":["42.7.7"],"introduced":["42.7.4"],"last_affected":[],"package":"postgresql-jdbc-driver","purl":"pkg:bitnami/postgresql-jdbc-driver","source":"BIT-postgresql-jdbc-driver-2025-49146"},{"ecosystem":"Maven","fixed":["42.7.7"],"introduced":["42.7.4"],"last_affected":[],"package":"org.postgresql:postgresql","purl":null,"source":"GHSA-hq9p-pm7w-8p54"},{"ecosystem":"Maven","fixed":["42.7.7"],"introduced":["42.7.4"],"last_affected":[],"package":"org.postgresql:postgresql","purl":"pkg:maven/org.postgresql/postgresql","source":"GHSA-hq9p-pm7w-8p54"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["42.7.7-1.1"],"introduced":["0"],"last_affected":[],"package":"postgresql-jdbc","purl":"pkg:rpm/opensuse/postgresql-jdbc\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15264-1"}],"prev":{"headline":"iTop admin can drop iTop database using webhooks","id":"CVE-2025-49145"},"products":["pgjdbc"],"published":"2025-06-11","related":[{"cvss_score":8.2,"headline":"Silent channel-binding authentication downgrade via unsupported certificate algorithms","id":"CVE-2026-54291","kev_date_added":null,"published":"2026-07-06"},{"cvss_score":8.1,"headline":"Moderate severity vulnerability that affects org.postgresql:pgjdbc-aggregate","id":"CVE-2018-10936","kev_date_added":null,"published":"2018-08-30"},{"cvss_score":7.5,"headline":"pgjdbc: Unbounded PBKDF2 iterations in SCRAM authentication allows CPU exhaustion DoS","id":"CVE-2026-42198","kev_date_added":null,"published":"2026-04-29"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-11","vendors":["pgjdbc"]},"summary":"Attackers can bypass channel binding requirements in the PostgreSQL JDBC driver, enabling man-in-the-middle attacks on secure connections.","url":"https://insights.sbomify.com/CVE-2025-49146/"}