# CVE-2025-49146: pgjdbc Client Allows Fallback to Insecure Authentication Despite channelBinding=require Configuration

> Attackers can bypass channel binding requirements in the PostgreSQL JDBC driver, enabling man-in-the-middle attacks on secure connections.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jun 2025
- **Updated:** 11 Jun 2025
- **Also known as:** BIT-postgresql-jdbc-driver-2025-49146, CLEANSTART-2026-XL50889, CLEANSTART-2026-XW89737, DEBIAN-CVE-2025-49146, GHSA-hq9p-pm7w-8p54, MINI-g73j-m8fr-9j3r, ROOT-APP-MAVEN-CVE-2025-49146, UBUNTU-CVE-2025-49146, openSUSE-SU-2025:15264-1

## What is CVE-2025-49146?

CVE-2025-49146 is a high-severity vulnerability in pgjdbc, published on 11 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

pgjdbc is an open source postgresql JDBC Driver. From 42.7.4 and until 42.7.7, when the PostgreSQL JDBC driver is configured with channel binding set to required (default value is prefer), the driver would incorrectly allow connections to proceed with authentication methods that do not support channel binding (such as password, MD5, GSS, or SSPI authentication). This could allow a man-in-the-middle attacker to intercept connections that users believed were protected by channel binding requirements. This vulnerability is fixed in 42.7.7.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2025-49146?

3 open source packages ship an affected version, including org.postgresql:postgresql and postgresql-jdbc-driver. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.postgresql:postgresql` | Maven | From 42.7.4 | 42.7.7 |
| `org.postgresql:postgresql` | Maven | From 42.7.4 | 42.7.7 |
| `postgresql-jdbc-driver` | Bitnami | From 42.7.4 | 42.7.7 |
| `postgresql-jdbc` | openSUSE:Tumbleweed | All versions | 42.7.7-1.1 |

Products: Postgresql Postgresql Jdbc Driver.

## How do I fix CVE-2025-49146?

Upgrade org.postgresql:postgresql to 42.7.7 or later.

## Is CVE-2025-49146 being exploited?

There is no known exploitation of CVE-2025-49146 in the wild and no public exploit code.

## Other vulnerabilities in pgjdbc

- [CVE-2026-54291](https://insights.sbomify.com/CVE-2026-54291/): Silent channel-binding authentication downgrade via unsupported certificate algorithms (high 8.2)
- [CVE-2018-10936](https://insights.sbomify.com/CVE-2018-10936/): Moderate severity vulnerability that affects org.postgresql:pgjdbc-aggregate (high 8.1)
- [CVE-2026-42198](https://insights.sbomify.com/CVE-2026-42198/): pgjdbc: Unbounded PBKDF2 iterations in SCRAM authentication allows CPU exhaustion DoS (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49146 and fix it if it is affected.

What it is: CVE-2025-49146 is a high-severity vulnerability in pgjdbc, published on 11 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-49146 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.postgresql:postgresql (Maven): affected from 42.7.4; fixed in 42.7.7
- org.postgresql:postgresql (Maven): affected from 42.7.4; fixed in 42.7.7
- postgresql-jdbc-driver (Bitnami): affected from 42.7.4; fixed in 42.7.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49146/ (Markdown: https://insights.sbomify.com/CVE-2025-49146/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49146
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49146
- OSV: https://osv.dev/vulnerability/CVE-2025-49146

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49146/
Summaries are generated and may contain mistakes; the official description above is the record.
