CVE-2025-49147 Umbraco.Cms Vulnerable to Disclosure of Configured Password Requirements
An attacker can retrieve configured password requirements via an anonymous endpoint, aiding brute-force attacks against Umbraco CMS users.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-49147?
CVE-2025-49147 is a medium-severity vulnerability in Umbraco Umbraco Cms, published on 24 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Umbraco, a free and open source .NET content management system, has a vulnerability in versions 10.0.0 through 10.8.10 and 13.0.0 through 13.9.1. Via a request to an anonymously authenticated endpoint it's possible to retrieve information about the configured password requirements. The information available is limited but would perhaps give some additional detail useful for someone attempting to brute force derive a user's password. This information was not exposed in Umbraco 7 or 8, nor in 14 or higher versions. The vulnerability is patched in versions 10.8.11 and 13.9.2.
Weakness: CWE-497
Which versions are affected by CVE-2025-49147?
4 open source packages ship an affected version, including Umbraco.Cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
Umbraco.Cms NuGet | From 10.0.0 | 10.8.11 |
Umbraco.Cms NuGet | From 10.0.0 | 10.8.11 |
Umbraco.Cms NuGet | From 13.0.0 | 13.9.2 |
Umbraco.Cms NuGet | From 13.0.0 | 13.9.2 |
Products include Umbraco Umbraco Cms.
How do I fix CVE-2025-49147?
Upgrade Umbraco.Cms to a fixed version for your release line: 10.8.11 or 13.9.2.
Is CVE-2025-49147 being exploited?
There is no known exploitation of CVE-2025-49147 in the wild and no public exploit code.
Other vulnerabilities in Umbraco Umbraco Cms
- CVE-2025-67288 Umbraco CMS has an arbitrary file upload vulnerability
- CVE-2014-10074 File upload in n/a
- CVE-2012-1301 Server-side request forgery in n/a
- CVE-2012-10054 Umbraco CMS < 4.7.1 codeEditorSave.asmx RCE
- CVE-2025-32017 Umbraco has a Management API Vulnerability to Path Traversal With Authenticated Users
Sources
Also known as GHSA-pgvc-6h2p-q4f6.