# CVE-2025-49147: Umbraco.Cms Vulnerable to Disclosure of Configured Password Requirements

> An attacker can retrieve configured password requirements via an anonymous endpoint, aiding brute-force attacks against Umbraco CMS users.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jun 2025
- **Updated:** 24 Jun 2025
- **Also known as:** GHSA-pgvc-6h2p-q4f6

## What is CVE-2025-49147?

CVE-2025-49147 is a medium-severity vulnerability in Umbraco Umbraco Cms, published on 24 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Umbraco, a free and open source .NET content management system, has a vulnerability in versions 10.0.0 through 10.8.10 and 13.0.0 through 13.9.1. Via a request to an anonymously authenticated endpoint it's possible to retrieve information about the configured password requirements. The information available is limited but would perhaps give some additional detail useful for someone attempting to brute force derive a user's password. This information was not exposed in Umbraco 7 or 8, nor in 14 or higher versions. The vulnerability is patched in versions 10.8.11 and 13.9.2.

Weakness: CWE-497 (Exposure of Sensitive System Information to an Unauthorized Control Sphere)

## Which versions are affected by CVE-2025-49147?

4 open source packages ship an affected version, including Umbraco.Cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Umbraco.Cms` | NuGet | From 10.0.0 | 10.8.11 |
| `Umbraco.Cms` | NuGet | From 10.0.0 | 10.8.11 |
| `Umbraco.Cms` | NuGet | From 13.0.0 | 13.9.2 |
| `Umbraco.Cms` | NuGet | From 13.0.0 | 13.9.2 |

Products: Umbraco Umbraco Cms.

## How do I fix CVE-2025-49147?

Upgrade Umbraco.Cms to a fixed version for your release line: 10.8.11 or 13.9.2.

## Is CVE-2025-49147 being exploited?

There is no known exploitation of CVE-2025-49147 in the wild and no public exploit code.

## Other vulnerabilities in Umbraco Umbraco Cms

- [CVE-2025-67288](https://insights.sbomify.com/CVE-2025-67288/): Umbraco CMS has an arbitrary file upload vulnerability (critical 10.0)
- [CVE-2014-10074](https://insights.sbomify.com/CVE-2014-10074/): File upload in n/a (critical 9.8)
- [CVE-2012-1301](https://insights.sbomify.com/CVE-2012-1301/): Server-side request forgery in n/a (critical 9.8)
- [CVE-2012-10054](https://insights.sbomify.com/CVE-2012-10054/): Umbraco CMS < 4.7.1 codeEditorSave.asmx RCE (critical 9.3)
- [CVE-2025-32017](https://insights.sbomify.com/CVE-2025-32017/): Umbraco has a Management API Vulnerability to Path Traversal With Authenticated Users (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49147 and fix it if it is affected.

What it is: CVE-2025-49147 is a medium-severity vulnerability in Umbraco Umbraco Cms, published on 24 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-49147 in the wild and no public exploit code.

Affected packages and fixed versions:
- Umbraco.Cms (NuGet): affected from 10.0.0; fixed in 10.8.11
- Umbraco.Cms (NuGet): affected from 10.0.0; fixed in 10.8.11
- Umbraco.Cms (NuGet): affected from 13.0.0; fixed in 13.9.2
- Umbraco.Cms (NuGet): affected from 13.0.0; fixed in 13.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49147/ (Markdown: https://insights.sbomify.com/CVE-2025-49147/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49147
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49147
- OSV: https://osv.dev/vulnerability/CVE-2025-49147

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49147/
Summaries are generated and may contain mistakes; the official description above is the record.
