# CVE-2025-49150: Cursor Agent Potentially Leaks Information using JSON schema

> A malicious agent can trigger arbitrary HTTP GET requests via JSON schema downloads, potentially exfiltrating sensitive data accessible to the editor.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 11 Jun 2025
- **Updated:** 11 Jun 2025

## What is CVE-2025-49150?

CVE-2025-49150 is a medium-severity server-side request forgery vulnerability in getcursor cursor, published on 11 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Cursor is a code editor built for programming with AI. Prior to 0.51.0, by default, the setting json.schemaDownload.enable was set to True. This means that by writing a JSON file, an attacker can trigger an arbitrary HTTP GET request that does not require user confirmation. Since the Cursor Agent can edit JSON files, this means a malicious agent, for example, after a prompt injection attack already succeeded, could trigger a GET request to an attacker controlled URL, potentially exfiltrating other data the agent may have access to. This vulnerability is fixed in 0.51.0.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-49150?


## How do I fix CVE-2025-49150?

No fix has been published for CVE-2025-49150 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-49150 being exploited?

There is no known exploitation of CVE-2025-49150 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49150 and fix it if it is affected.

What it is: CVE-2025-49150 is a medium-severity server-side request forgery vulnerability in getcursor cursor, published on 11 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-49150 in the wild and no public exploit code.

Affected product: getcursor cursor. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49150/ (Markdown: https://insights.sbomify.com/CVE-2025-49150/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49150
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49150
- OSV: https://osv.dev/vulnerability/CVE-2025-49150

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49150/
Summaries are generated and may contain mistakes; the official description above is the record.
