CVE-2025-4922 Nomad Vulnerable To Incorrect ACL Policy Lookup Attached To A Job

High 8.1 Published Updated

Attackers can bypass intended ACL restrictions due to incorrect prefix-based policy lookup, potentially gaining unauthorized access to job resources.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-4922?

CVE-2025-4922 is a high-severity missing authorization vulnerability in HashiCorp Nomad, published on 11 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Nomad Community and Nomad Enterprise (“Nomad”) prefix-based ACL policy lookup can lead to incorrect rule application and shadowing. This vulnerability, identified as CVE-2025-4922, is fixed in Nomad Community Edition 1.10.2 and Nomad Enterprise 1.10.2, 1.9.10, and 1.8.14.

Weakness: CWE-266

Which versions are affected by CVE-2025-4922?

3 open source packages ship an affected version, including github.com/hashicorp/nomad. It affects 1 product.

PackageAffectedFixed in
github.com/hashicorp/nomad GoAll versions1.10.2
github.com/hashicorp/nomad GoAll versions1.10.2
github.com/hashicorp/nomad GoAll versions1.10.2

Products include Hashicorp Nomad.

How do I fix CVE-2025-4922?

Upgrade github.com/hashicorp/nomad to 1.10.2 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-4922 being exploited?

There is no known exploitation of CVE-2025-4922 in the wild and no public exploit code.

Sources

Also known as GHSA-rx97-6c62-55mf, GO-2025-3758, UBUNTU-CVE-2025-4922.

Is CVE-2025-4922 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free