CVE-2025-49222 Mattermost Shared Channel Upload Type Validation Bypass

Medium 6.8 Published Updated

System admins can bypass upload type validation in shared channels to place arbitrary files in filesystem directories, potentially leading to code execution.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-49222?

CVE-2025-49222 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 21 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Mattermost versions 10.8.x <= 10.8.3, 10.5.x <= 10.5.8, 9.11.x <= 9.11.17, 10.9.x <= 10.9.2, 10.10.x <= 10.10.0 fail to validate upload types in remote cluster upload sessions which allows a system admin to upload non-attachment file types via shared channels that could potentially be placed in arbitrary filesystem directories.

Weakness: CWE-434

Which versions are affected by CVE-2025-49222?

20 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost-server GoFrom 10.10.010.10.1
github.com/mattermost/mattermost-server GoFrom 10.10.010.10.1
github.com/mattermost/mattermost-server GoFrom 10.5.010.5.9
github.com/mattermost/mattermost-server GoFrom 10.5.010.5.9
github.com/mattermost/mattermost-server GoFrom 10.8.010.8.4
github.com/mattermost/mattermost-server GoFrom 10.8.010.8.4
14 more packages
github.com/mattermost/mattermost-server GoFrom 10.9.010.9.3
github.com/mattermost/mattermost-server GoFrom 10.9.010.9.3
github.com/mattermost/mattermost-server GoFrom 9.11.09.11.18
github.com/mattermost/mattermost-server GoFrom 9.11.09.11.18
github.com/mattermost/mattermost-server GoFrom 9.11.0+incompatible9.11.18+incompatible, 10.5.9+incompatible, 10.8.4+incompatible, 10.9.3+incompatible, 10.10.1+incompatible
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
github.com/mattermost/mattermost-server/v5 GoAll versions to 5.39.3None
github.com/mattermost/mattermost-server/v5 GoAll versions to 5.39.3None
github.com/mattermost/mattermost-server/v6 GoAll versionsNone
github.com/mattermost/mattermost-server/v6 GoAll versions to 5.7.2None
github.com/mattermost/mattermost-server/v6 GoAll versions to 5.7.2None
github.com/mattermost/mattermost/server/v8 GoAll versionsNone
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250708173752-d6b35c41f0ae5
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250708173752-d6b35c41f0ae5

Products include Mattermost Mattermost Server.

How do I fix CVE-2025-49222?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.10.1, 10.5.9, 10.8.4 or 10.9.3.

Is CVE-2025-49222 being exploited?

There is no known exploitation of CVE-2025-49222 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as GHSA-q453-638c-h4mr, GO-2025-3904.

Is CVE-2025-49222 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free