CVE-2025-49506 Apache Portable Runtime Utility: apr_password_validate() vulnerable to timing attack

High 7.5 Published Updated

An attacker can potentially leak password or hash content via timing side-channel attacks in apr_password_validate() on platforms lacking crypt().

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-49506?

CVE-2025-49506 is a high-severity vulnerability in Apache Portable Runtime Utility, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

APR-util versions 1.6.3 (and earlier) function apr_password_validate() was not constant-time with regards to hashes or passwords comparisons, potentially leaking their content via a side channel timing attack particularly on platforms without crypt() such as  Windows, BeOS, NetWare, or Android.

Users are recommended to upgrade to version 1.6.4, which fixes this issue.

Weakness: CWE-208

Which versions are affected by CVE-2025-49506?

1 open source package ship an affected version, including apr-util. It affects 1 product.

PackageAffectedFixed in
apr-util BitnamiFrom 1.2.01.6.4

Products include Apache Apr-Util.

How do I fix CVE-2025-49506?

Upgrade apr-util to 1.6.4 or later.

Is CVE-2025-49506 being exploited?

There is no known exploitation of CVE-2025-49506 in the wild and no public exploit code.

Sources

Also known as ALPINE-CVE-2025-49506, AZL-94628, BELL-CVE-2025-49506, BIT-apr-util-2025-49506, CLSA-2026-1786553851, CLSA-2026-1786623875 and 4 more.

Is CVE-2025-49506 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free