{"answers":{"affected":"1 open source package ship an affected version, including apr-util. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-49506 in the wild and no public exploit code.","fix":"Upgrade apr-util to 1.6.4 or later.","what":"CVE-2025-49506 is a high-severity vulnerability in Apache Portable Runtime Utility, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-49506 and fix it if it is affected.\n\nWhat it is: CVE-2025-49506 is a high-severity vulnerability in Apache Portable Runtime Utility, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-49506 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apr-util (Bitnami): affected from 1.2.0; fixed in 1.6.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-49506/ (Markdown: https://insights.sbomify.com/CVE-2025-49506/index.md)","id":"CVE-2025-49506","markdown":"https://insights.sbomify.com/CVE-2025-49506/index.md","name":"CVE-2025-49506","record":{"aliases":["ALPINE-CVE-2025-49506","AZL-94628","BELL-CVE-2025-49506","BIT-apr-util-2025-49506","CLSA-2026-1786553851","CLSA-2026-1786623875","DEBIAN-CVE-2025-49506","ECHO-601d-e0ee-c283","GHSA-73wm-47mq-62r5","UBUNTU-CVE-2025-49506"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Portable Runtime Utility","requires_auth":"none","summary":"An attacker can potentially leak password or hash content via timing side-channel attacks in apr_password_validate() on platforms lacking crypt().","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"apr-util","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-208","name":"Observable Timing Discrepancy"}],"description":"APR-util versions 1.6.3 (and earlier) function apr_password_validate() was not constant-time with regards to hashes or passwords comparisons, potentially leaking their content via a side channel timing attack particularly on platforms without crypt() such as  Windows, BeOS, NetWare, or Android.\n\nUsers are recommended to upgrade to version 1.6.4, which fixes this issue.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Portable Runtime Utility: apr_password_validate() vulnerable to timing attack","id":"CVE-2025-49506","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"information_disclosure","year":"2025"},"n_packages":1,"n_references":1,"next":{"headline":"WordPress CozyStay theme \u003c 1.7.1 - PHP Object Injection vulnerability","id":"CVE-2025-49507"},"packages":[{"ecosystem":"Bitnami","fixed":["1.6.4"],"introduced":["1.2.0"],"last_affected":[],"package":"apr-util","purl":"pkg:bitnami/apr-util","source":"BIT-apr-util-2025-49506"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2025-49495"},"products":["Apache Portable Runtime Utility"],"published":"2026-08-06","related":[{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2009-2412","kev_date_added":null,"published":"2009-08-06"},{"cvss_score":9.1,"headline":"Apache Portable Runtime Utility: apr-util XML stack recursion crash","id":"CVE-2026-32327","kev_date_added":null,"published":"2026-08-06"},{"cvss_score":9.1,"headline":"Apache Portable Runtime Utility: SQL Injection in apr_dbd_oracle","id":"CVE-2026-34191","kev_date_added":null,"published":"2026-08-06"},{"cvss_score":7.5,"headline":"Apache Portable Runtime Utility: Heap buffer overflow in APR redis client","id":"CVE-2026-34501","kev_date_added":null,"published":"2026-08-06"},{"cvss_score":7.5,"headline":"Apache Portable Runtime Utility: Heap buffer overflow in APR memcached client","id":"CVE-2026-34502","kev_date_added":null,"published":"2026-08-06"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2009-1955","kev_date_added":null,"published":"2009-06-06"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-06","vendors":["Apache Software Foundation"]},"summary":"An attacker can potentially leak password or hash content via timing side-channel attacks in apr_password_validate() on platforms lacking crypt().","url":"https://insights.sbomify.com/CVE-2025-49506/"}