# CVE-2025-49506: Apache Portable Runtime Utility: apr_password_validate() vulnerable to timing attack

> An attacker can potentially leak password or hash content via timing side-channel attacks in apr_password_validate() on platforms lacking crypt().

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Aug 2026
- **Updated:** 6 Aug 2026
- **Also known as:** ALPINE-CVE-2025-49506, AZL-94628, BELL-CVE-2025-49506, BIT-apr-util-2025-49506, CLSA-2026-1786553851, CLSA-2026-1786623875, DEBIAN-CVE-2025-49506, ECHO-601d-e0ee-c283, GHSA-73wm-47mq-62r5, UBUNTU-CVE-2025-49506

## What is CVE-2025-49506?

CVE-2025-49506 is a high-severity vulnerability in Apache Portable Runtime Utility, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

APR-util versions 1.6.3 (and earlier) function apr_password_validate() was not constant-time with regards to hashes or passwords comparisons, potentially leaking their content via a side channel timing attack particularly on platforms without crypt() such as  Windows, BeOS, NetWare, or Android.

Users are recommended to upgrade to version 1.6.4, which fixes this issue.

Weakness: CWE-208 (Observable Timing Discrepancy)

## Which versions are affected by CVE-2025-49506?

1 open source package ship an affected version, including apr-util. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apr-util` | Bitnami | From 1.2.0 | 1.6.4 |

Products: Apache Apr-Util.

## How do I fix CVE-2025-49506?

Upgrade apr-util to 1.6.4 or later.

## Is CVE-2025-49506 being exploited?

There is no known exploitation of CVE-2025-49506 in the wild and no public exploit code.

## Other vulnerabilities in Apache Portable Runtime Utility

- [CVE-2009-2412](https://insights.sbomify.com/CVE-2009-2412/): Integer overflow in n/a (critical 10.0)
- [CVE-2026-32327](https://insights.sbomify.com/CVE-2026-32327/): Apache Portable Runtime Utility: apr-util XML stack recursion crash (critical 9.1)
- [CVE-2026-34191](https://insights.sbomify.com/CVE-2026-34191/): Apache Portable Runtime Utility: SQL Injection in apr_dbd_oracle (critical 9.1)
- [CVE-2026-34501](https://insights.sbomify.com/CVE-2026-34501/): Apache Portable Runtime Utility: Heap buffer overflow in APR redis client (high 7.5)
- [CVE-2026-34502](https://insights.sbomify.com/CVE-2026-34502/): Apache Portable Runtime Utility: Heap buffer overflow in APR memcached client (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49506 and fix it if it is affected.

What it is: CVE-2025-49506 is a high-severity vulnerability in Apache Portable Runtime Utility, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-49506 in the wild and no public exploit code.

Affected packages and fixed versions:
- apr-util (Bitnami): affected from 1.2.0; fixed in 1.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49506/ (Markdown: https://insights.sbomify.com/CVE-2025-49506/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49506
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49506
- OSV: https://osv.dev/vulnerability/CVE-2025-49506

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49506/
Summaries are generated and may contain mistakes; the official description above is the record.
