# CVE-2025-49549: Adobe Commerce | Incorrect Authorization (CWE-863)

> A high-privileged attacker can bypass security measures to gain limited unauthorized access in Adobe Commerce without user interaction.

- **Severity:** Low 2.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jun 2025
- **Updated:** 25 Jun 2025
- **Also known as:** GHSA-85jx-x9r4-45m2

## What is CVE-2025-49549?

CVE-2025-49549 is a low-severity missing authorization vulnerability in Adobe Commerce, published on 25 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Adobe Commerce versions 2.4.8, 2.4.7-p5, 2.4.6-p10, 2.4.5-p12, 2.4.4-p13 and earlier are affected by an Incorrect Authorization vulnerability that could result in a Security feature bypass. A high-privileged attacker could leverage this vulnerability to bypass security measures and gain limited unauthorized access. Exploitation of this issue does not require user interaction.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-49549?

10 open source packages ship an affected version, including magento/community-edition and magento/project-community-edition. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `magento/community-edition` | Packagist | All versions | None |
| `magento/community-edition` | Packagist | All versions | None |
| `magento/community-edition` | Packagist | All versions | 2.4.5-p13 |
| `magento/community-edition` | Packagist | All versions | 2.4.5-p13 |
| `magento/community-edition` | Packagist | From 2.4.6-p1 | 2.4.6-p11 |
| `magento/community-edition` | Packagist | From 2.4.6-p1 | 2.4.6-p11 |
| `magento/community-edition` | Packagist | From 2.4.7-beta1 | 2.4.7-p6 |
| `magento/community-edition` | Packagist | From 2.4.7-beta1 | 2.4.7-p6 |
| `magento/project-community-edition` | Packagist | All versions to 2.0.2 | None |
| `magento/project-community-edition` | Packagist | All versions to 2.0.2 | None |

Products: Adobe Commerce, Adobe Commerce B2b, Adobe Magento.

## How do I fix CVE-2025-49549?

Upgrade magento/community-edition to a fixed version for your release line: 2.4.5-p13, 2.4.6-p11 or 2.4.7-p6.

## Is CVE-2025-49549 being exploited?

There is no known exploitation of CVE-2025-49549 in the wild and no public exploit code.

## Other vulnerabilities in Adobe Commerce

- [CVE-2026-75650](https://insights.sbomify.com/CVE-2026-75650/): Adobe Commerce and Magento Improper Neutralization of Special Elements Used in a Template Engine (critical 10.0, exploited in the wild)
- [CVE-2024-34102](https://insights.sbomify.com/CVE-2024-34102/): Adobe Commerce and Magento Open Source Improper Restriction of XML External Entity Reference (XXE) (critical 9.8, exploited in the wild)
- [CVE-2022-24086](https://insights.sbomify.com/CVE-2022-24086/): Adobe Commerce and Magento Open Source Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-48356](https://insights.sbomify.com/CVE-2026-48356/): Adobe Commerce and Magento Unrestricted Upload of File with Dangerous Type (critical 9.3, exploited in the wild)
- [CVE-2026-71362](https://insights.sbomify.com/CVE-2026-71362/): Adobe Commerce and Magento Incorrect Authorization Vulnerability (critical 9.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49549 and fix it if it is affected.

What it is: CVE-2025-49549 is a low-severity missing authorization vulnerability in Adobe Commerce, published on 25 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-49549 in the wild and no public exploit code.

Affected packages and fixed versions:
- magento/community-edition (Packagist): affected all versions; no fix listed
- magento/community-edition (Packagist): affected all versions; no fix listed
- magento/community-edition (Packagist): affected all versions; fixed in 2.4.5-p13
- magento/community-edition (Packagist): affected all versions; fixed in 2.4.5-p13
- magento/community-edition (Packagist): affected from 2.4.6-p1; fixed in 2.4.6-p11
- magento/community-edition (Packagist): affected from 2.4.6-p1; fixed in 2.4.6-p11
- magento/community-edition (Packagist): affected from 2.4.7-beta1; fixed in 2.4.7-p6
- magento/community-edition (Packagist): affected from 2.4.7-beta1; fixed in 2.4.7-p6
- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed
- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49549/ (Markdown: https://insights.sbomify.com/CVE-2025-49549/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49549
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49549
- OSV: https://osv.dev/vulnerability/CVE-2025-49549

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49549/
Summaries are generated and may contain mistakes; the official description above is the record.
