CVE-2025-49575 Citizen allows stored XSS in Command Palette tip messages

Medium 6.5 Published Updated

Stored XSS in Citizen skin allows attackers with editinterface rights to inject arbitrary HTML into Command Palette tips, potentially compromising user sessions.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-49575?

CVE-2025-49575 is a medium-severity cross-site scripting vulnerability in StarCitizenTools mediawiki-skins-Citizen, published on 12 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Citizen is a MediaWiki skin that makes extensions part of the cohesive experience. Multiple system messages are inserted into the CommandPaletteFooter as raw HTML, allowing anybody who can edit those messages to insert arbitrary HTML into the DOM. This impacts wikis where a group has the `editinterface` but not the `editsitejs` user right. This vulnerability is fixed in 3.3.1.

Weakness: CWE-79

Which versions are affected by CVE-2025-49575?

2 open source packages ship an affected version, including starcitizentools/citizen-skin. It affects 1 product.

PackageAffectedFixed in
starcitizentools/citizen-skin PackagistFrom 2.4.23.3.1
starcitizentools/citizen-skin PackagistFrom 2.4.23.3.1

Products include Starcitizen.tools Citizen.

How do I fix CVE-2025-49575?

Upgrade starcitizentools/citizen-skin to 3.3.1 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-49575 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49575 exists.

Sources

Also known as GHSA-4c2h-67qq-vm87.

Is CVE-2025-49575 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free