# CVE-2025-49575: Citizen allows stored XSS in Command Palette tip messages

> Stored XSS in Citizen skin allows attackers with editinterface rights to inject arbitrary HTML into Command Palette tips, potentially compromising user sessions.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2025
- **Updated:** 12 Jun 2025
- **Also known as:** GHSA-4c2h-67qq-vm87

## What is CVE-2025-49575?

CVE-2025-49575 is a medium-severity cross-site scripting vulnerability in StarCitizenTools mediawiki-skins-Citizen, published on 12 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Citizen is a MediaWiki skin that makes extensions part of the cohesive experience. Multiple system messages are inserted into the CommandPaletteFooter as raw HTML, allowing anybody who can edit those messages to insert arbitrary HTML into the DOM. This impacts wikis where a group has the `editinterface` but not the `editsitejs` user right. This vulnerability is fixed in 3.3.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-49575?

2 open source packages ship an affected version, including starcitizentools/citizen-skin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `starcitizentools/citizen-skin` | Packagist | From 2.4.2 | 3.3.1 |
| `starcitizentools/citizen-skin` | Packagist | From 2.4.2 | 3.3.1 |

Products: Starcitizen.tools Citizen.

## How do I fix CVE-2025-49575?

Upgrade starcitizentools/citizen-skin to 3.3.1 or later.

## Is CVE-2025-49575 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49575 exists.

## Other vulnerabilities in StarCitizenTools mediawiki-skins-Citizen

- [CVE-2025-53368](https://insights.sbomify.com/CVE-2025-53368/): Citizen is vulnerable to stored XSS attack in the legacy search bar (high 8.6)
- [CVE-2025-53370](https://insights.sbomify.com/CVE-2025-53370/): Citizen stored XSS vulnerability through short descriptions (high 8.6)
- [CVE-2025-49576](https://insights.sbomify.com/CVE-2025-49576/): Citizen allows stored XSS in search no result messages (medium 6.5)
- [CVE-2025-49577](https://insights.sbomify.com/CVE-2025-49577/): Citizen allows stored XSS in preference menu headings (medium 6.5)
- [CVE-2025-49578](https://insights.sbomify.com/CVE-2025-49578/): Citizen allows stored XSS in user registration date message (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49575 and fix it if it is affected.

What it is: CVE-2025-49575 is a medium-severity cross-site scripting vulnerability in StarCitizenTools mediawiki-skins-Citizen, published on 12 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49575 exists.

Affected packages and fixed versions:
- starcitizentools/citizen-skin (Packagist): affected from 2.4.2; fixed in 3.3.1
- starcitizentools/citizen-skin (Packagist): affected from 2.4.2; fixed in 3.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49575/ (Markdown: https://insights.sbomify.com/CVE-2025-49575/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49575
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49575
- OSV: https://osv.dev/vulnerability/CVE-2025-49575

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49575/
Summaries are generated and may contain mistakes; the official description above is the record.
