CVE-2025-49579 Citizen allows stored XSS in menu heading message

Medium 6.5 Published Updated

Stored XSS in Citizen MediaWiki skin allows attackers with editinterface rights to inject arbitrary HTML into menu headings.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-49579?

CVE-2025-49579 is a medium-severity cross-site scripting vulnerability in StarCitizenTools mediawiki-skins-Citizen, published on 12 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Citizen is a MediaWiki skin that makes extensions part of the cohesive experience. All system messages in menu headings using the Menu.mustache template are inserted as raw HTML, allowing anybody who can edit those messages to insert arbitrary HTML into the DOM. This impacts wikis where a group has the `editinterface` but not the `editsitejs` user right. This vulnerability is fixed in 3.3.1.

Weakness: CWE-79

Which versions are affected by CVE-2025-49579?

2 open source packages ship an affected version, including starcitizentools/citizen-skin. It affects 1 product.

PackageAffectedFixed in
starcitizentools/citizen-skin PackagistFrom 2.4.23.3.1
starcitizentools/citizen-skin PackagistFrom 2.4.23.3.1

Products include Starcitizen.tools Citizen.

How do I fix CVE-2025-49579?

Upgrade starcitizentools/citizen-skin to 3.3.1 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-49579 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49579 exists.

Sources

Also known as GHSA-g3cp-pq72-hjpv.

Is CVE-2025-49579 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free