# CVE-2025-49580: XWiki allows privilege escalation through link refactoring

> Attackers can escalate privileges and execute scripts by renaming or moving linked pages, allowing unauthorized code execution in XWiki.

- **Severity:** High 8.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Jun 2025
- **Updated:** 13 Jun 2025
- **Also known as:** GHSA-jm43-hrq7-r7w6

## What is CVE-2025-49580?

CVE-2025-49580 is a high-severity vulnerability in Xwiki Xwiki, published on 13 Jun 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

XWiki is a generic wiki platform. From 8.2 and 7.4.5 until 17.1.0-rc-1, 16.10.4, and 16.4.7, pages can gain script or programming rights when they contain a link and the target of the link is renamed or moved. This might lead to execution of scripts contained in xobjects that should have never been executed. This vulnerability is fixed in 17.1.0-rc-1, 16.10.4, and 16.4.7.

Weakness: CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2025-49580?

8 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-refactoring-default. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-refactoring-default` | Maven | From 16.5.0-rc-1 | 16.10.4 |
| `org.xwiki.platform:xwiki-platform-refactoring-default` | Maven | From 16.5.0-rc-1 | 16.10.4 |
| `org.xwiki.platform:xwiki-platform-refactoring-default` | Maven | From 17.0.0-rc-1 | 17.1.0-rc-1 |
| `org.xwiki.platform:xwiki-platform-refactoring-default` | Maven | From 17.0.0-rc-1 | 17.1.0-rc-1 |
| `org.xwiki.platform:xwiki-platform-refactoring-default` | Maven | From 7.4.5 | 16.4.7 |
| `org.xwiki.platform:xwiki-platform-refactoring-default` | Maven | From 7.4.5 | 16.4.7 |
| `org.xwiki.platform:xwiki-platform-refactoring-default` | Maven | From 8.2 | 16.4.7 |
| `org.xwiki.platform:xwiki-platform-refactoring-default` | Maven | From 8.2 | 16.4.7 |

Products: Xwiki Xwiki.

## How do I fix CVE-2025-49580?

Upgrade org.xwiki.platform:xwiki-platform-refactoring-default to a fixed version for your release line: 16.10.4, 17.1.0-rc-1 or 16.4.7.

## Is CVE-2025-49580 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49580 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49580 and fix it if it is affected.

What it is: CVE-2025-49580 is a high-severity vulnerability in Xwiki Xwiki, published on 13 Jun 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49580 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-refactoring-default (Maven): affected from 16.5.0-rc-1; fixed in 16.10.4
- org.xwiki.platform:xwiki-platform-refactoring-default (Maven): affected from 16.5.0-rc-1; fixed in 16.10.4
- org.xwiki.platform:xwiki-platform-refactoring-default (Maven): affected from 17.0.0-rc-1; fixed in 17.1.0-rc-1
- org.xwiki.platform:xwiki-platform-refactoring-default (Maven): affected from 17.0.0-rc-1; fixed in 17.1.0-rc-1
- org.xwiki.platform:xwiki-platform-refactoring-default (Maven): affected from 7.4.5; fixed in 16.4.7
- org.xwiki.platform:xwiki-platform-refactoring-default (Maven): affected from 7.4.5; fixed in 16.4.7
- org.xwiki.platform:xwiki-platform-refactoring-default (Maven): affected from 8.2; fixed in 16.4.7
- org.xwiki.platform:xwiki-platform-refactoring-default (Maven): affected from 8.2; fixed in 16.4.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49580/ (Markdown: https://insights.sbomify.com/CVE-2025-49580/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49580
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49580
- OSV: https://osv.dev/vulnerability/CVE-2025-49580

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49580/
Summaries are generated and may contain mistakes; the official description above is the record.
