# CVE-2025-49581: XWiki allows remote code execution through default value of wiki macro wiki-type parameters

> Attackers with edit rights can execute arbitrary code by exploiting default wiki macro parameters, leading to full system compromise.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jun 2025
- **Updated:** 13 Jun 2025
- **Also known as:** GHSA-9875-cw22-f7cx

## What is CVE-2025-49581?

CVE-2025-49581 is a high-severity code injection vulnerability in Xwiki Xwiki, published on 13 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki is a generic wiki platform. Any user with edit right on a page (could be the user's profile) can execute code (Groovy, Python, Velocity) with programming right by defining a wiki macro. This allows full access to the whole XWiki installation. The main problem is that if a wiki macro parameter allows wiki syntax, its default value is executed with the rights of the author of the document where it is used. This can be exploited by overriding a macro like the children macro that is used in a page that has programming right like the page XWiki.ChildrenMacro and thus allows arbitrary script macros. This vulnerability has been patched in XWiki 16.4.7, 16.10.3 and 17.0.0 by executing wiki parameters with the rights of the wiki macro's author when the parameter's value is the default value.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-270 (Privilege Context Switching Error), CWE-250 (Execution with Unnecessary Privileges)

## Which versions are affected by CVE-2025-49581?

10 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-rendering-wikimacro-store. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-rendering-wikimacro-store` | Maven | From 11.10.11 | None |
| `org.xwiki.platform:xwiki-platform-rendering-wikimacro-store` | Maven | From 11.10.11 | None |
| `org.xwiki.platform:xwiki-platform-rendering-wikimacro-store` | Maven | From 12.6.3 | None |
| `org.xwiki.platform:xwiki-platform-rendering-wikimacro-store` | Maven | From 12.6.3 | None |
| `org.xwiki.platform:xwiki-platform-rendering-wikimacro-store` | Maven | From 12.8-rc-1 | 16.4.7 |
| `org.xwiki.platform:xwiki-platform-rendering-wikimacro-store` | Maven | From 12.8-rc-1 | 16.4.7 |
| `org.xwiki.platform:xwiki-platform-rendering-wikimacro-store` | Maven | From 16.5.0-rc-1 | 16.10.3 |
| `org.xwiki.platform:xwiki-platform-rendering-wikimacro-store` | Maven | From 16.5.0-rc-1 | 16.10.3 |
| `org.xwiki.platform:xwiki-platform-rendering-wikimacro-store` | Maven | From 17.0.0-rc-1 | 17.0.0 |
| `org.xwiki.platform:xwiki-platform-rendering-wikimacro-store` | Maven | From 17.0.0-rc-1 | 17.0.0 |

Products: Xwiki Xwiki.

## How do I fix CVE-2025-49581?

Upgrade org.xwiki.platform:xwiki-platform-rendering-wikimacro-store to a fixed version for your release line: 16.4.7, 16.10.3 or 17.0.0.

## Is CVE-2025-49581 being exploited?

There is no known exploitation of CVE-2025-49581 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49581 and fix it if it is affected.

What it is: CVE-2025-49581 is a high-severity code injection vulnerability in Xwiki Xwiki, published on 13 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-49581 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-rendering-wikimacro-store (Maven): affected from 11.10.11; no fix listed
- org.xwiki.platform:xwiki-platform-rendering-wikimacro-store (Maven): affected from 11.10.11; no fix listed
- org.xwiki.platform:xwiki-platform-rendering-wikimacro-store (Maven): affected from 12.6.3; no fix listed
- org.xwiki.platform:xwiki-platform-rendering-wikimacro-store (Maven): affected from 12.6.3; no fix listed
- org.xwiki.platform:xwiki-platform-rendering-wikimacro-store (Maven): affected from 12.8-rc-1; fixed in 16.4.7
- org.xwiki.platform:xwiki-platform-rendering-wikimacro-store (Maven): affected from 12.8-rc-1; fixed in 16.4.7
- org.xwiki.platform:xwiki-platform-rendering-wikimacro-store (Maven): affected from 16.5.0-rc-1; fixed in 16.10.3
- org.xwiki.platform:xwiki-platform-rendering-wikimacro-store (Maven): affected from 16.5.0-rc-1; fixed in 16.10.3
- org.xwiki.platform:xwiki-platform-rendering-wikimacro-store (Maven): affected from 17.0.0-rc-1; fixed in 17.0.0
- org.xwiki.platform:xwiki-platform-rendering-wikimacro-store (Maven): affected from 17.0.0-rc-1; fixed in 17.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49581/ (Markdown: https://insights.sbomify.com/CVE-2025-49581/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49581
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49581
- OSV: https://osv.dev/vulnerability/CVE-2025-49581

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49581/
Summaries are generated and may contain mistakes; the official description above is the record.
