# CVE-2025-49584: XWiki makes title of inaccessible pages available through the class property values REST API

> Attackers can retrieve titles of inaccessible pages via the REST API, potentially exposing sensitive information if page names are obfuscated.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jun 2025
- **Updated:** 13 Jun 2025
- **Also known as:** GHSA-mvp5-qx9c-c3fv

## What is CVE-2025-49584?

CVE-2025-49584 is a high-severity vulnerability in Xwiki Xwiki, published on 13 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki is a generic wiki platform. In XWiki Platform versions 10.9 through 16.4.6, 16.5.0-rc-1 through 16.10.2, and 17.0.0-rc-1, the title of every single page whose reference is known can be accessed through the REST API as long as an XClass with a page property is accessible, this is the default for an XWiki installation. This allows an attacker to get titles of pages whose reference is known, one title per request. This doesn't affect fully private wikis as the REST endpoint checks access rights on the XClass definition. The impact on confidentiality depends on the strategy for page names. By default, page names match the title, so the impact should be low but if page names are intentionally obfuscated because the titles are sensitive, the impact could be high. This has been fixed in XWiki 16.4.7, 16.10.3 and 17.0.0 by adding access control checks before getting the title of any page.

Weakness: CWE-201 (Insertion of Sensitive Information Into Sent Data)

## Which versions are affected by CVE-2025-49584?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-rest-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 10.9 | 16.4.7 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 10.9 | 16.4.7 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 16.5.0-rc-1 | 16.10.3 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 16.5.0-rc-1 | 16.10.3 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 17.0.0-rc-1 | 17.0.0 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 17.0.0-rc-1 | 17.0.0 |

Products: Xwiki Xwiki.

## How do I fix CVE-2025-49584?

Upgrade org.xwiki.platform:xwiki-platform-rest-server to a fixed version for your release line: 16.4.7, 16.10.3 or 17.0.0.

## Is CVE-2025-49584 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49584 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49584 and fix it if it is affected.

What it is: CVE-2025-49584 is a high-severity vulnerability in Xwiki Xwiki, published on 13 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49584 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 10.9; fixed in 16.4.7
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 10.9; fixed in 16.4.7
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 16.5.0-rc-1; fixed in 16.10.3
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 16.5.0-rc-1; fixed in 16.10.3
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 17.0.0-rc-1; fixed in 17.0.0
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 17.0.0-rc-1; fixed in 17.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49584/ (Markdown: https://insights.sbomify.com/CVE-2025-49584/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49584
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49584
- OSV: https://osv.dev/vulnerability/CVE-2025-49584

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49584/
Summaries are generated and may contain mistakes; the official description above is the record.
