CVE-2025-49585 XWiki does not require right warnings for XClass definitions
Attackers can inject malicious code into XClass definitions that executes with elevated privileges when edited by authorized users.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-49585?
CVE-2025-49585 is a high-severity code injection vulnerability in Xwiki Xwiki, published on 13 Jun 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
XWiki is a generic wiki platform. In versions before 15.10.16, 16.0.0-rc-1 through 16.4.6, and 16.5.0-rc-1 through 16.10.1, when an attacker without script or programming right creates an XClass definition in XWiki (requires edit right), and that same document is later edited by a user with script, admin, or programming right, malicious code could be executed with the rights of the editing user without prior warning. In particular, this concerns custom display code, the script of computed properties and queries in database list properties. Note that warnings before editing documents with dangerous properties have only been introduced in XWiki 15.9, before that version, this was a known issue and the advice was simply to be careful. This has been patched in XWiki 16.10.2, 16.4.7 and 15.10.16 by adding an analysis for the respective XClass properties.
Weakness: CWE-357
Which versions are affected by CVE-2025-49585?
6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-security-requiredrights-default. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-security-requiredrights-default Maven | All versions | 15.10.16 |
org.xwiki.platform:xwiki-platform-security-requiredrights-default Maven | All versions | 15.10.16 |
org.xwiki.platform:xwiki-platform-security-requiredrights-default Maven | From 16.0.0-rc-1 | 16.4.7 |
org.xwiki.platform:xwiki-platform-security-requiredrights-default Maven | From 16.0.0-rc-1 | 16.4.7 |
org.xwiki.platform:xwiki-platform-security-requiredrights-default Maven | From 16.5.0-rc-1 | 16.10.2 |
org.xwiki.platform:xwiki-platform-security-requiredrights-default Maven | From 16.5.0-rc-1 | 16.10.2 |
Products include Xwiki Xwiki.
How do I fix CVE-2025-49585?
Upgrade org.xwiki.platform:xwiki-platform-security-requiredrights-default to a fixed version for your release line: 15.10.16, 16.4.7 or 16.10.2.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2025-49585 being exploited?
There is no known exploitation of CVE-2025-49585 in the wild and no public exploit code.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-59w6-r9hm-439h.