# CVE-2025-49585: XWiki does not require right warnings for XClass definitions

> Attackers can inject malicious code into XClass definitions that executes with elevated privileges when edited by authorized users.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Jun 2025
- **Updated:** 13 Jun 2025
- **Also known as:** GHSA-59w6-r9hm-439h

## What is CVE-2025-49585?

CVE-2025-49585 is a high-severity code injection vulnerability in Xwiki Xwiki, published on 13 Jun 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

XWiki is a generic wiki platform. In versions before 15.10.16, 16.0.0-rc-1 through 16.4.6, and 16.5.0-rc-1 through 16.10.1, when an attacker without script or programming right creates an XClass definition in XWiki (requires edit right), and that same document is later edited by a user with script, admin, or programming right, malicious code could be executed with the rights of the editing user without prior warning. In particular, this concerns custom display code, the script of computed properties and queries in database list properties. Note that warnings before editing documents with dangerous properties have only been introduced in XWiki 15.9, before that version, this was a known issue and the advice was simply to be careful. This has been patched in XWiki 16.10.2, 16.4.7 and 15.10.16 by adding an analysis for the respective XClass properties.

Weakness: CWE-357 (Insufficient UI Warning of Dangerous Operations)

## Which versions are affected by CVE-2025-49585?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-security-requiredrights-default. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-security-requiredrights-default` | Maven | All versions | 15.10.16 |
| `org.xwiki.platform:xwiki-platform-security-requiredrights-default` | Maven | All versions | 15.10.16 |
| `org.xwiki.platform:xwiki-platform-security-requiredrights-default` | Maven | From 16.0.0-rc-1 | 16.4.7 |
| `org.xwiki.platform:xwiki-platform-security-requiredrights-default` | Maven | From 16.0.0-rc-1 | 16.4.7 |
| `org.xwiki.platform:xwiki-platform-security-requiredrights-default` | Maven | From 16.5.0-rc-1 | 16.10.2 |
| `org.xwiki.platform:xwiki-platform-security-requiredrights-default` | Maven | From 16.5.0-rc-1 | 16.10.2 |

Products: Xwiki Xwiki.

## How do I fix CVE-2025-49585?

Upgrade org.xwiki.platform:xwiki-platform-security-requiredrights-default to a fixed version for your release line: 15.10.16, 16.4.7 or 16.10.2.

## Is CVE-2025-49585 being exploited?

There is no known exploitation of CVE-2025-49585 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49585 and fix it if it is affected.

What it is: CVE-2025-49585 is a high-severity code injection vulnerability in Xwiki Xwiki, published on 13 Jun 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-49585 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-security-requiredrights-default (Maven): affected all versions; fixed in 15.10.16
- org.xwiki.platform:xwiki-platform-security-requiredrights-default (Maven): affected all versions; fixed in 15.10.16
- org.xwiki.platform:xwiki-platform-security-requiredrights-default (Maven): affected from 16.0.0-rc-1; fixed in 16.4.7
- org.xwiki.platform:xwiki-platform-security-requiredrights-default (Maven): affected from 16.0.0-rc-1; fixed in 16.4.7
- org.xwiki.platform:xwiki-platform-security-requiredrights-default (Maven): affected from 16.5.0-rc-1; fixed in 16.10.2
- org.xwiki.platform:xwiki-platform-security-requiredrights-default (Maven): affected from 16.5.0-rc-1; fixed in 16.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49585/ (Markdown: https://insights.sbomify.com/CVE-2025-49585/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49585
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49585
- OSV: https://osv.dev/vulnerability/CVE-2025-49585

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49585/
Summaries are generated and may contain mistakes; the official description above is the record.
