# CVE-2025-49586: XWiki allows remote code execution through preview of XClass changes in AWM editor

> Authenticated users can achieve remote code execution and gain programming rights by exploiting the preview feature in App Within Minutes applications.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jun 2025
- **Updated:** 13 Jun 2025
- **Also known as:** GHSA-jp4x-w9cj-97q7

## What is CVE-2025-49586?

CVE-2025-49586 is a high-severity code injection vulnerability in Xwiki Xwiki, published on 13 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki is an open-source wiki software platform. Any XWiki user with edit right on at least one App Within Minutes application (the default for all users XWiki) can obtain programming right/perform remote code execution by editing the application. This vulnerability has been fixed in XWiki 17.0.0, 16.4.7, and 16.10.3.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-49586?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 16.5.0-rc-1 | 16.10.3 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 16.5.0-rc-1 | 16.10.3 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 17.0.0-rc-1 | 17.0.0 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 17.0.0-rc-1 | 17.0.0 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 7.2-milestone-2 | 16.4.7 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 7.2-milestone-2 | 16.4.7 |

Products: Xwiki Xwiki.

## How do I fix CVE-2025-49586?

Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 16.10.3, 17.0.0 or 16.4.7.

## Is CVE-2025-49586 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49586 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49586 and fix it if it is affected.

What it is: CVE-2025-49586 is a high-severity code injection vulnerability in Xwiki Xwiki, published on 13 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49586 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 16.5.0-rc-1; fixed in 16.10.3
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 16.5.0-rc-1; fixed in 16.10.3
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 17.0.0-rc-1; fixed in 17.0.0
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 17.0.0-rc-1; fixed in 17.0.0
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 7.2-milestone-2; fixed in 16.4.7
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 7.2-milestone-2; fixed in 16.4.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49586/ (Markdown: https://insights.sbomify.com/CVE-2025-49586/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49586
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49586
- OSV: https://osv.dev/vulnerability/CVE-2025-49586

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49586/
Summaries are generated and may contain mistakes; the official description above is the record.
