# CVE-2025-49589: PCSX2 Contains a Stack-based Buffer Overflow in IOP Console Logging

> A stack-based buffer overflow in PCSX2 allows remote code execution via crafted disc images when IOP Console Logging is enabled.

- **Severity:** Medium 6.1 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:P/VC:N/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Jun 2025
- **Updated:** 13 Jun 2025
- **Also known as:** DEBIAN-CVE-2025-49589, GHSA-f494-4xf7-xj35, UBUNTU-CVE-2025-49589

## What is CVE-2025-49589?

CVE-2025-49589 is a medium-severity memory corruption vulnerability in pcsx2, published on 12 Jun 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

PCSX2 is a free and open-source PlayStation 2 (PS2) emulator. A stack-based buffer overflow exists in the Kprintf_HLE function of PCSX2 versions up to 2.3.414. Opening a disc image that logs a specially crafted message may allow a remote attacker to execute arbitrary code if the user enabled IOP Console Logging. This vulnerability is fixed in 2.3.414.

Weakness: CWE-121 (Stack-based Buffer Overflow)

## Which versions are affected by CVE-2025-49589?


## How do I fix CVE-2025-49589?

Upgrade to a fixed version.

## Is CVE-2025-49589 being exploited?

There is no known exploitation of CVE-2025-49589 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49589 and fix it if it is affected.

What it is: CVE-2025-49589 is a medium-severity memory corruption vulnerability in pcsx2, published on 12 Jun 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-49589 in the wild and no public exploit code.

Affected product: pcsx2. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49589/ (Markdown: https://insights.sbomify.com/CVE-2025-49589/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49589
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49589
- OSV: https://osv.dev/vulnerability/CVE-2025-49589

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49589/
Summaries are generated and may contain mistakes; the official description above is the record.
