{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49590 exists.","fix":"No fix has been published for CVE-2025-49590 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-49590 is a low-severity cross-site scripting vulnerability in cryptpad, published on 18 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-49590 and fix it if it is affected.\n\nWhat it is: CVE-2025-49590 is a low-severity cross-site scripting vulnerability in cryptpad, published on 18 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49590 exists.\n\nAffected product: cryptpad. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-49590/ (Markdown: https://insights.sbomify.com/CVE-2025-49590/index.md)","id":"CVE-2025-49590","markdown":"https://insights.sbomify.com/CVE-2025-49590/index.md","name":"CVE-2025-49590","record":{"aliases":["GHSA-vq9h-x3gr-v8rj"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"CryptPad collaboration suite","requires_auth":"none","summary":"Attackers can execute arbitrary scripts via a bypass in the Link Bouncer filter, potentially compromising user accounts.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"cryptpad","vendor":"xwiki"}],"cvss":{"score":2.9,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-692","name":"Incomplete Denylist to Cross-Site Scripting"}],"description":"CryptPad is a collaboration suite. Prior to version 2025.3.0, the \"Link Bouncer\" functionality attempts to filter javascript URIs to prevent Cross-Site Scripting (XSS), however this can be bypassed. There is an \"early allow\" code path that happens before the URI's protocol/scheme is checked, which a maliciously crafted URI can follow. This issue has been patched in version 2025.3.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"CryptPad Dom-Based Cross-Site Scripting (XSS) Vulnerability","id":"CVE-2025-49590","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2025"},"n_packages":0,"n_references":3,"next":{"headline":"CryptPad 2FA Bypass Vulnerability","id":"CVE-2025-49591"},"packages":[],"prev":{"headline":"PCSX2 Contains a Stack-based Buffer Overflow in IOP Console Logging","id":"CVE-2025-49589"},"products":["cryptpad"],"published":"2025-06-18","related":[{"cvss_score":8.7,"headline":"CryptPad unbounded WebSocket frame flood","id":"CVE-2025-51846","kev_date_added":null,"published":"2026-04-30"},{"cvss_score":7.4,"headline":"CryptPad 2FA Bypass Vulnerability","id":"CVE-2025-49591","kev_date_added":null,"published":"2025-06-18"},{"cvss_score":6.5,"headline":"Denial of service in n/a","id":"CVE-2019-15302","kev_date_added":null,"published":"2019-09-11"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2017-1000051","kev_date_added":null,"published":"2017-07-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-23","vendors":["cryptpad"]},"summary":"Attackers can execute arbitrary scripts via a bypass in the Link Bouncer filter, potentially compromising user accounts.","url":"https://insights.sbomify.com/CVE-2025-49590/"}