# CVE-2025-49590: CryptPad Dom-Based Cross-Site Scripting (XSS) Vulnerability

> Attackers can execute arbitrary scripts via a bypass in the Link Bouncer filter, potentially compromising user accounts.

- **Severity:** Low 2.9 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Jun 2025
- **Updated:** 23 Jun 2025
- **Also known as:** GHSA-vq9h-x3gr-v8rj

## What is CVE-2025-49590?

CVE-2025-49590 is a low-severity cross-site scripting vulnerability in cryptpad, published on 18 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CryptPad is a collaboration suite. Prior to version 2025.3.0, the "Link Bouncer" functionality attempts to filter javascript URIs to prevent Cross-Site Scripting (XSS), however this can be bypassed. There is an "early allow" code path that happens before the URI's protocol/scheme is checked, which a maliciously crafted URI can follow. This issue has been patched in version 2025.3.0.

Weakness: CWE-692 (Incomplete Denylist to Cross-Site Scripting)

## Which versions are affected by CVE-2025-49590?

It affects 1 product.


Products: Xwiki Cryptpad.

## How do I fix CVE-2025-49590?

No fix has been published for CVE-2025-49590 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-49590 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49590 exists.

## Other vulnerabilities in cryptpad

- [CVE-2025-51846](https://insights.sbomify.com/CVE-2025-51846/): CryptPad unbounded WebSocket frame flood (high 8.7)
- [CVE-2025-49591](https://insights.sbomify.com/CVE-2025-49591/): CryptPad 2FA Bypass Vulnerability (high 7.4)
- [CVE-2019-15302](https://insights.sbomify.com/CVE-2019-15302/): Denial of service in n/a (medium 6.5)
- [CVE-2017-1000051](https://insights.sbomify.com/CVE-2017-1000051/): Cross-site scripting in n/a (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49590 and fix it if it is affected.

What it is: CVE-2025-49590 is a low-severity cross-site scripting vulnerability in cryptpad, published on 18 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49590 exists.

Affected product: cryptpad. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49590/ (Markdown: https://insights.sbomify.com/CVE-2025-49590/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49590
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49590
- OSV: https://osv.dev/vulnerability/CVE-2025-49590

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49590/
Summaries are generated and may contain mistakes; the official description above is the record.
