# CVE-2025-49592: n8n Login Flow has Open Redirect Vulnerability

> Authenticated users can be redirected to attacker-controlled domains after login, enabling phishing and credential theft.

- **Severity:** Medium 4.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Jun 2025
- **Updated:** 26 Jun 2025
- **Also known as:** GHSA-5vj6-wjr7-5v9f

## What is CVE-2025-49592?

CVE-2025-49592 is a medium-severity vulnerability in N8n N8n, published on 26 Jun 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

n8n is a workflow automation platform. Versions prior to 1.98.0 have an Open Redirect vulnerability in the login flow. Authenticated users can be redirected to untrusted, attacker-controlled domains after logging in, by crafting malicious URLs with a misleading redirect query parameter. This may lead to phishing attacks by impersonating the n8n UI on lookalike domains (e.g., n8n.local.evil.com), credential or 2FA theft if users are tricked into re-entering sensitive information, and/or reputation risk due to the visual similarity between attacker-controlled domains and trusted ones. The vulnerability affects anyone hosting n8n and exposing the `/signin` endpoint to users. The issue has been patched in version 1.98.0. All users should upgrade to this version or later. The fix introduces strict origin validation for redirect URLs, ensuring only same-origin or relative paths are allowed after login.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2025-49592?

2 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | All versions | 1.98.0 |
| `n8n` | npm | All versions | 1.98.0 |

Products: N8n N8n.

## How do I fix CVE-2025-49592?

Upgrade n8n to 1.98.0 or later.

## Is CVE-2025-49592 being exploited?

There is no known exploitation of CVE-2025-49592 in the wild and no public exploit code.

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49592 and fix it if it is affected.

What it is: CVE-2025-49592 is a medium-severity vulnerability in N8n N8n, published on 26 Jun 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-49592 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected all versions; fixed in 1.98.0
- n8n (npm): affected all versions; fixed in 1.98.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49592/ (Markdown: https://insights.sbomify.com/CVE-2025-49592/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49592
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49592
- OSV: https://osv.dev/vulnerability/CVE-2025-49592

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49592/
Summaries are generated and may contain mistakes; the official description above is the record.
