# CVE-2025-49593: Portainer HTTP Headers May Leak to Malicious Container Registries

> Portainer administrators may leak session tokens and credentials to malicious registries if tricked into registering them, requiring an upgrade to fix.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 17 Jun 2025
- **Updated:** 18 Jun 2025
- **Also known as:** GHSA-h5jw-8c32-xfv6

## What is CVE-2025-49593?

CVE-2025-49593 is a medium-severity vulnerability in portainer, published on 17 Jun 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Portainer Community Edition is a lightweight service delivery platform for containerized applications that can be used to manage Docker, Swarm, Kubernetes and ACI environments. Prior to STS version 2.31.0 and LTS version 2.27.7, if a Portainer administrator can be convinced to register a malicious container registry, or an existing container registry can be taken over, HTTP Headers (including registry authentication credentials or Portainer session tokens) may be leaked to that registry. This issue has been patched in STS version 2.31.0 and LTS version 2.27.7.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-49593?


## How do I fix CVE-2025-49593?

No fix has been published for CVE-2025-49593 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-49593 being exploited?

There is no known exploitation of CVE-2025-49593 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49593 and fix it if it is affected.

What it is: CVE-2025-49593 is a medium-severity vulnerability in portainer, published on 17 Jun 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-49593 in the wild and no public exploit code.

Affected product: portainer. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49593/ (Markdown: https://insights.sbomify.com/CVE-2025-49593/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49593
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49593
- OSV: https://osv.dev/vulnerability/CVE-2025-49593

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49593/
Summaries are generated and may contain mistakes; the official description above is the record.
