{"answers":{"affected":"2 open source packages ship an affected version, including @modelcontextprotocol/inspector.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49596 exists.","fix":"Upgrade @modelcontextprotocol/inspector to 0.14.1 or later.","what":"CVE-2025-49596 is a critical missing authorization vulnerability in modelcontextprotocol inspector, published on 13 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-49596 and fix it if it is affected.\n\nWhat it is: CVE-2025-49596 is a critical missing authorization vulnerability in modelcontextprotocol inspector, published on 13 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49596 exists.\n\nAffected packages and fixed versions:\n- @modelcontextprotocol/inspector (npm): affected all versions; fixed in 0.14.1\n- @modelcontextprotocol/inspector (npm): affected all versions; fixed in 0.14.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-49596/ (Markdown: https://insights.sbomify.com/CVE-2025-49596/index.md)","id":"CVE-2025-49596","markdown":"https://insights.sbomify.com/CVE-2025-49596/index.md","name":"CVE-2025-49596","record":{"aliases":["GHSA-7f8r-222p-6f5g","ROOT-APP-NPM-CVE-2025-49596"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"MCP Inspector","requires_auth":"none","summary":"Unauthenticated access to the MCP Inspector proxy allows attackers to execute arbitrary commands, requiring an immediate upgrade.","user_interaction":"required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.4,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-306","name":"Missing Authentication for Critical Functionality"}],"description":"The MCP inspector is a developer tool for testing and debugging MCP servers. Versions of MCP Inspector below 0.14.1 are vulnerable to remote code execution due to lack of authentication between the Inspector client and proxy, allowing unauthenticated requests to launch MCP commands over stdio. Users should immediately upgrade to version 0.14.1 or later to address these vulnerabilities.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2025-07-03","github_poc":4,"max_poc_stars":1,"metasploit":0,"nuclei":1,"refs":[{"date":"2026-06-06T03:06:39Z","kind":"github_poc","ref":"https://github.com/RajSidwadkar/UAP-protocol","stars":1,"title":"A unified, security-first wire protocol for tool access and agent coordination. UAP eliminates CVE-2025-49596 and MCP tool-poisoning vulnerabilities using Ed25519-signed CapabilityCards, mandatory mTLS, Keycloak IdP authentication, and per-call ephemeral Docker sandboxing."},{"date":"2025-07-03T16:12:27Z","kind":"github_poc","ref":"https://github.com/ashiqrehan-21/MCP-Inspector-CVE-2025-49596","stars":0,"title":"MCP-Inspector-vulncheck is a Python script that checks if an MCP Inspector server is vulnerable to CVE-2025-49596. It tests whether the /sse endpoint responds to unauthenticated requests, indicating a potential security flaw. The script is simple to use and provides clear output on whether the target server is likely vulnerable or patched."},{"date":"2026-03-25T01:53:42Z","kind":"github_poc","ref":"https://github.com/pppxo/CVE-2025-49596-PoC","stars":0,"title":"PoC for CVE-2025-49596 on linux targets"},{"date":"2026-04-10T01:09:30Z","kind":"github_poc","ref":"https://github.com/acseguin21/trust-boundary-ctf","stars":0,"title":"Browser-based MCP CTF — OAuth token confusion and session isolation failure (CVE-2025-49596 pattern). DevTools only."},{"date":null,"kind":"nuclei","ref":"http/cves/2025/CVE-2025-49596.yaml","stars":null,"title":"MCP Inspector \u003c 0.14.0 UnauthenticatedRemote Code Execution"}],"tier":"weaponised"},"has_fix":true,"headline":"MCP Inspector proxy server lacks authentication between the Inspector client and proxy","id":"CVE-2025-49596","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"missing_authorization","year":"2025"},"n_packages":2,"n_references":4,"next":{"headline":"handcraftedinthealps goodby-csv Potential Gadget Chain allowing Remote Code Execution","id":"CVE-2025-49597"},"packages":[{"ecosystem":"npm","fixed":["0.14.1"],"introduced":["0"],"last_affected":[],"package":"@modelcontextprotocol/inspector","purl":null,"source":"GHSA-7f8r-222p-6f5g"},{"ecosystem":"npm","fixed":["0.14.1"],"introduced":["0"],"last_affected":[],"package":"@modelcontextprotocol/inspector","purl":"pkg:npm/%40modelcontextprotocol/inspector","source":"GHSA-7f8r-222p-6f5g"}],"prev":{"headline":"n8n Vulnerable to Denial of Service via Malformed Binary Data Requests","id":"CVE-2025-49595"},"products":["inspector"],"published":"2025-06-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-07-09","vendors":["modelcontextprotocol"]},"summary":"Unauthenticated access to the MCP Inspector proxy allows attackers to execute arbitrary commands, requiring an immediate upgrade.","url":"https://insights.sbomify.com/CVE-2025-49596/"}