# CVE-2025-49596: MCP Inspector proxy server lacks authentication between the Inspector client and proxy

> Unauthenticated access to the MCP Inspector proxy allows attackers to execute arbitrary commands, requiring an immediate upgrade.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Jun 2025
- **Updated:** 9 Jul 2025
- **Also known as:** GHSA-7f8r-222p-6f5g, ROOT-APP-NPM-CVE-2025-49596

## What is CVE-2025-49596?

CVE-2025-49596 is a critical missing authorization vulnerability in modelcontextprotocol inspector, published on 13 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The MCP inspector is a developer tool for testing and debugging MCP servers. Versions of MCP Inspector below 0.14.1 are vulnerable to remote code execution due to lack of authentication between the Inspector client and proxy, allowing unauthenticated requests to launch MCP commands over stdio. Users should immediately upgrade to version 0.14.1 or later to address these vulnerabilities.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2025-49596?

2 open source packages ship an affected version, including @modelcontextprotocol/inspector.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@modelcontextprotocol/inspector` | npm | All versions | 0.14.1 |
| `@modelcontextprotocol/inspector` | npm | All versions | 0.14.1 |

## How do I fix CVE-2025-49596?

Upgrade @modelcontextprotocol/inspector to 0.14.1 or later.

## Is CVE-2025-49596 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49596 exists.

Public exploit code:

- A unified, security-first wire protocol for tool access and agent coordination. UAP eliminates CVE-2025-49596 and MCP tool-poisoning vulnerabilities using Ed25519-signed CapabilityCards, mandatory mTLS, Keycloak IdP authentication, and per-call ephemeral Docker sandboxing. (github_poc): https://github.com/RajSidwadkar/UAP-protocol
- MCP-Inspector-vulncheck is a Python script that checks if an MCP Inspector server is vulnerable to CVE-2025-49596. It tests whether the /sse endpoint responds to unauthenticated requests, indicating a potential security flaw. The script is simple to use and provides clear output on whether the target server is likely vulnerable or patched. (github_poc): https://github.com/ashiqrehan-21/MCP-Inspector-CVE-2025-49596
- PoC for CVE-2025-49596 on linux targets (github_poc): https://github.com/pppxo/CVE-2025-49596-PoC
- Browser-based MCP CTF — OAuth token confusion and session isolation failure (CVE-2025-49596 pattern). DevTools only. (github_poc): https://github.com/acseguin21/trust-boundary-ctf
- MCP Inspector < 0.14.0 UnauthenticatedRemote Code Execution (nuclei): http/cves/2025/CVE-2025-49596.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49596 and fix it if it is affected.

What it is: CVE-2025-49596 is a critical missing authorization vulnerability in modelcontextprotocol inspector, published on 13 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49596 exists.

Affected packages and fixed versions:
- @modelcontextprotocol/inspector (npm): affected all versions; fixed in 0.14.1
- @modelcontextprotocol/inspector (npm): affected all versions; fixed in 0.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49596/ (Markdown: https://insights.sbomify.com/CVE-2025-49596/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49596
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49596
- OSV: https://osv.dev/vulnerability/CVE-2025-49596

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49596/
Summaries are generated and may contain mistakes; the official description above is the record.
