# CVE-2025-49597: handcraftedinthealps goodby-csv Potential Gadget Chain allowing Remote Code Execution

> The goodby-csv library contains a gadget chain that enables remote code execution when used in applications with insecure deserialization vulnerabilities.

- **Severity:** Low 3.9 (`CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jun 2025
- **Updated:** 23 Jun 2025
- **Also known as:** GHSA-x3c7-22c8-prg7

## What is CVE-2025-49597?

CVE-2025-49597 is a low-severity unsafe deserialization vulnerability in handcraftedinthealps goodby-csv, published on 13 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

handcraftedinthealps goodby-csv is a highly memory efficient, flexible and extendable open-source CSV import/export library. Prior to 1.4.3, goodby-csv could be used as part of a chain of methods that is exploitable when an insecure deserialization vulnerability exists in an application. This so-called "gadget chain" presents no direct threat but is a vector that can be used to achieve remote code execution if the application deserializes untrusted data due to another vulnerability. The problem is patched with Version 1.4.3.

Weakness: CWE-915 (Improperly Controlled Modification of Dynamically-Determined Object Attributes)

## Which versions are affected by CVE-2025-49597?

2 open source packages ship an affected version, including handcraftedinthealps/goodby-csv.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `handcraftedinthealps/goodby-csv` | Packagist | All versions | 1.4.3 |
| `handcraftedinthealps/goodby-csv` | Packagist | All versions | 1.4.3 |

## How do I fix CVE-2025-49597?

Upgrade handcraftedinthealps/goodby-csv to 1.4.3 or later.

## Is CVE-2025-49597 being exploited?

There is no known exploitation of CVE-2025-49597 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49597 and fix it if it is affected.

What it is: CVE-2025-49597 is a low-severity unsafe deserialization vulnerability in handcraftedinthealps goodby-csv, published on 13 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-49597 in the wild and no public exploit code.

Affected packages and fixed versions:
- handcraftedinthealps/goodby-csv (Packagist): affected all versions; fixed in 1.4.3
- handcraftedinthealps/goodby-csv (Packagist): affected all versions; fixed in 1.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49597/ (Markdown: https://insights.sbomify.com/CVE-2025-49597/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49597
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49597
- OSV: https://osv.dev/vulnerability/CVE-2025-49597

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49597/
Summaries are generated and may contain mistakes; the official description above is the record.
