# CVE-2025-49630: Apache HTTP Server: mod_proxy_http2 denial of service

> Untrusted clients can cause a denial of service in Apache HTTP Server when using a specific reverse proxy configuration with HTTP/2 backends.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2025
- **Updated:** 4 Nov 2025
- **Also known as:** ALPINE-CVE-2025-49630, ALSA-2025:14625, ALSA-2025:14983, AZL-65133, AZL-65142, AZL-65175, AZL-65220, BELL-CVE-2025-49630, BIT-apache-2025-49630, CLSA-2025-1756324356, CLSA-2025-1762784415, CLSA-2026-1787222082, DEBIAN-CVE-2025-49630, GHSA-72h2-3r97-f454, MINI-jm4f-mx93-wr77, OESA-2025-2076, RHSA-2025:14625, RHSA-2025:14983, RHSA-2025:15725, RHSA-2025:15726, RHSA-2025:15727, RLSA-2025:14625, RLSA-2025:14983, UBUNTU-CVE-2025-49630

## What is CVE-2025-49630?

CVE-2025-49630 is a high-severity denial of service vulnerability in Apache Http Server, published on 10 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In certain proxy configurations, a denial of service attack against Apache HTTP Server versions 2.4.26 through to 2.4.63 can be triggered by untrusted clients causing an assertion in mod_proxy_http2.

Configurations affected are a reverse proxy is configured for an HTTP/2 backend, with ProxyPreserveHost set to "on".

Weakness: CWE-617 (Reachable Assertion)

## Which versions are affected by CVE-2025-49630?

1 open source package ship an affected version, including apache. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | From 2.4.26 | 2.4.64 |
| `mod_http2` | AlmaLinux:10 | All versions | 2.0.29-2.el10_0.1 |
| `mod_http2` | AlmaLinux:9 | All versions | 2.0.26-4.el9_6.1 |
| `mod_http2` | Red Hat:enterprise_linux:10.0 | All versions | 0:2.0.29-2.el10_0.1 |
| `mod_http2-debuginfo` | Red Hat:enterprise_linux:10.0 | All versions | 0:2.0.29-2.el10_0.1 |
| `mod_http2-debugsource` | Red Hat:enterprise_linux:10.0 | All versions | 0:2.0.29-2.el10_0.1 |
| `mod_http2` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.0.26-4.el9_6.1 |
| `mod_http2-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.0.26-4.el9_6.1 |
| `mod_http2-debugsource` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.0.26-4.el9_6.1 |
| `mod_http2` | Red Hat:rhel_e4s:9.0::appstream | All versions | 0:1.15.19-3.el9_0.7 |
| `mod_http2-debuginfo` | Red Hat:rhel_e4s:9.0::appstream | All versions | 0:1.15.19-3.el9_0.7 |
| `mod_http2-debugsource` | Red Hat:rhel_e4s:9.0::appstream | All versions | 0:1.15.19-3.el9_0.7 |
| `mod_http2` | Red Hat:rhel_e4s:9.2::appstream | All versions | 0:1.15.19-4.el9_2.7 |
| `mod_http2-debuginfo` | Red Hat:rhel_e4s:9.2::appstream | All versions | 0:1.15.19-4.el9_2.7 |
| `mod_http2-debugsource` | Red Hat:rhel_e4s:9.2::appstream | All versions | 0:1.15.19-4.el9_2.7 |
| `mod_http2` | Red Hat:rhel_eus:9.4::appstream | All versions | 0:2.0.26-2.el9_4.2 |
| `mod_http2-debuginfo` | Red Hat:rhel_eus:9.4::appstream | All versions | 0:2.0.26-2.el9_4.2 |
| `mod_http2-debugsource` | Red Hat:rhel_eus:9.4::appstream | All versions | 0:2.0.26-2.el9_4.2 |
| `mod_http2` | Rocky Linux:10 | All versions | 0:2.0.29-2.el10_0.1 |
| `mod_http2` | Rocky Linux:9 | All versions | 0:2.0.26-4.el9_6.1 |

Products: Apache Http Server.

## How do I fix CVE-2025-49630?

Upgrade apache to 2.4.64 or later.

## Is CVE-2025-49630 being exploited?

There is no known exploitation of CVE-2025-49630 in the wild and no public exploit code.

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49630 and fix it if it is affected.

What it is: CVE-2025-49630 is a high-severity denial of service vulnerability in Apache Http Server, published on 10 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-49630 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected from 2.4.26; fixed in 2.4.64

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49630/ (Markdown: https://insights.sbomify.com/CVE-2025-49630/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49630
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49630
- OSV: https://osv.dev/vulnerability/CVE-2025-49630

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49630/
Summaries are generated and may contain mistakes; the official description above is the record.
