{"answers":{"affected":"3 open source packages ship an affected version, including keras.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49655 exists.","fix":"Upgrade keras to 3.11.3 or later.","what":"CVE-2025-49655 is a critical unsafe deserialization vulnerability in Keras, published on 17 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-49655 and fix it if it is affected.\n\nWhat it is: CVE-2025-49655 is a critical unsafe deserialization vulnerability in Keras, published on 17 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-49655 exists.\n\nAffected packages and fixed versions:\n- keras (PyPI): affected from 3.11.0; fixed in 3.11.3\n- keras (PyPI): affected from 3.11.0; fixed in 3.11.3\n- keras (PyPI): affected from 3.11.0; fixed in 3.11.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-49655/ (Markdown: https://insights.sbomify.com/CVE-2025-49655/index.md)","id":"CVE-2025-49655","markdown":"https://insights.sbomify.com/CVE-2025-49655/index.md","name":"CVE-2025-49655","record":{"aliases":["DEBIAN-CVE-2025-49655","GHSA-cvhh-q5g5-qprp","PYSEC-2026-368","UBUNTU-CVE-2025-49655"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Keras deep learning library","requires_auth":"none","summary":"Attackers can execute arbitrary code by tricking users into loading malicious Keras files, bypassing safe mode restrictions.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"HiddenLayer","cpe":[],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Deserialization of untrusted data can occur in versions of the Keras framework running versions 3.11.0 up to but not including 3.11.3, enabling a maliciously uploaded Keras file containing a TorchModuleWrapper class to run arbitrary code on an end user’s system when loaded despite safe mode being enabled. The vulnerability can be triggered through both local and remote files.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Keras framework vulnerable to deserialization of untrusted data","id":"CVE-2025-49655","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"Apache Jena: Administrative users can create files outside the server directory space via the admin UI","id":"CVE-2025-49656"},"packages":[{"ecosystem":"PyPI","fixed":["3.11.3"],"introduced":["3.11.0"],"last_affected":[],"package":"keras","purl":null,"source":"GHSA-cvhh-q5g5-qprp"},{"ecosystem":"PyPI","fixed":["3.11.3"],"introduced":["3.11.0"],"last_affected":[],"package":"keras","purl":"pkg:pypi/keras","source":"GHSA-cvhh-q5g5-qprp"},{"ecosystem":"PyPI","fixed":["3.11.3"],"introduced":["3.11.0"],"last_affected":[],"package":"keras","purl":"pkg:pypi/keras","source":"PYSEC-2026-368"}],"prev":{"headline":"Exposure of sensitive Information allows account takeover","id":"CVE-2025-49653"},"products":["Keras"],"published":"2025-10-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-10-17","vendors":["Keras"]},"summary":"Attackers can execute arbitrary code by tricking users into loading malicious Keras files, bypassing safe mode restrictions.","url":"https://insights.sbomify.com/CVE-2025-49655/"}