# CVE-2025-49656: Apache Jena: Administrative users can create files outside the server directory space via the admin UI

> Administrative users can create files outside the server directory space via the admin UI in Apache Jena Fuseki.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jul 2025
- **Updated:** 4 Nov 2025
- **Also known as:** DEBIAN-CVE-2025-49656, GHSA-jq2c-m8gg-mqcm, UBUNTU-CVE-2025-49656

## What is CVE-2025-49656?

CVE-2025-49656 is a high-severity path traversal vulnerability in Apache Jena, published on 21 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Users with administrator access can create databases files outside the files area of the Fuseki server.

This issue affects Apache Jena version up to 5.4.0.

Users are recommended to upgrade to version 5.5.0, which fixes the issue.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-49656?

2 open source packages ship an affected version, including org.apache.jena:jena-fuseki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.jena:jena-fuseki` | Maven | All versions | 5.5.0 |
| `org.apache.jena:jena-fuseki` | Maven | All versions | 5.5.0 |

Products: Apache Jena.

## How do I fix CVE-2025-49656?

Upgrade org.apache.jena:jena-fuseki to 5.5.0 or later.

## Is CVE-2025-49656 being exploited?

There is no known exploitation of CVE-2025-49656 in the wild and no public exploit code.

## Other vulnerabilities in Apache Jena

- [CVE-2022-28890](https://insights.sbomify.com/CVE-2022-28890/): Processing external DTDs (critical 9.8)
- [CVE-2025-50151](https://insights.sbomify.com/CVE-2025-50151/): Apache Jena: Configuration files uploaded by administrative users are not check properly (high 8.8)
- [CVE-2023-32200](https://insights.sbomify.com/CVE-2023-32200/): Apache Jena: Exposure of execution in script engine expressions. (high 8.8)
- [CVE-2021-39239](https://insights.sbomify.com/CVE-2021-39239/): XML External Entity (XXE) vulnerability (high 7.5)
- [CVE-2023-22665](https://insights.sbomify.com/CVE-2023-22665/): Apache Jena: Exposure of arbitrary execution in script engine expressions. (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-49656 and fix it if it is affected.

What it is: CVE-2025-49656 is a high-severity path traversal vulnerability in Apache Jena, published on 21 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-49656 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.jena:jena-fuseki (Maven): affected all versions; fixed in 5.5.0
- org.apache.jena:jena-fuseki (Maven): affected all versions; fixed in 5.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-49656/ (Markdown: https://insights.sbomify.com/CVE-2025-49656/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-49656
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-49656
- OSV: https://osv.dev/vulnerability/CVE-2025-49656

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-49656/
Summaries are generated and may contain mistakes; the official description above is the record.
