CVE-2025-4979 Insufficient Granularity of Access Control in GitLab

Medium 4.9 Published Updated

An attacker can reveal masked CI variables they did not author by observing HTTP responses when creating their own variable in the GitLab WebUI.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-4979?

CVE-2025-4979 is a medium-severity vulnerability in Gitlab Gitlab, published on 22 May 2025. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions before 17.10.7, 17.11 before 17.11.3, and 18.0 before 18.0.1. An attacker may be able to reveal masked or hidden CI variables (that they did not author) in the WebUI, by simply creating their own variable and observing the HTTP response.

Weakness: CWE-1220

Which versions are affected by CVE-2025-4979?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions17.11.3, 18.0.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-4979?

Upgrade gitlab to a fixed version for your release line: 17.11.3 or 18.0.1.

Is CVE-2025-4979 being exploited?

There is no known exploitation of CVE-2025-4979 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-4979, GHSA-9vrq-hh79-6v9m, UBUNTU-CVE-2025-4979.

Is CVE-2025-4979 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free