# CVE-2025-4979: Insufficient Granularity of Access Control in GitLab

> An attacker can reveal masked CI variables they did not author by observing HTTP responses when creating their own variable in the GitLab WebUI.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 May 2025
- **Updated:** 22 May 2025
- **Also known as:** BIT-gitlab-2025-4979, GHSA-9vrq-hh79-6v9m, UBUNTU-CVE-2025-4979

## What is CVE-2025-4979?

CVE-2025-4979 is a medium-severity vulnerability in Gitlab Gitlab, published on 22 May 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

An issue has been discovered in GitLab CE/EE affecting all versions before 17.10.7, 17.11 before 17.11.3, and 18.0 before 18.0.1. An attacker may be able to reveal masked or hidden CI variables (that they did not author) in the WebUI, by simply creating their own variable and observing the HTTP response.

Weakness: CWE-1220 (Insufficient Granularity of Access Control)

## Which versions are affected by CVE-2025-4979?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | All versions | 17.11.3, 18.0.1 |

Products: Gitlab Gitlab.

## How do I fix CVE-2025-4979?

Upgrade gitlab to a fixed version for your release line: 17.11.3 or 18.0.1.

## Is CVE-2025-4979 being exploited?

There is no known exploitation of CVE-2025-4979 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-4979 and fix it if it is affected.

What it is: CVE-2025-4979 is a medium-severity vulnerability in Gitlab Gitlab, published on 22 May 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-4979 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected all versions; fixed in 17.11.3, 18.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-4979/ (Markdown: https://insights.sbomify.com/CVE-2025-4979/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-4979
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-4979
- OSV: https://osv.dev/vulnerability/CVE-2025-4979

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-4979/
Summaries are generated and may contain mistakes; the official description above is the record.
