CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
Authenticated users can achieve remote code execution via path traversal in archive extraction, affecting default Mattermost configurations.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-4981?
CVE-2025-4981 is a critical path traversal vulnerability in Mattermost Mattermost Server, published on 20 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 10.5.x <= 10.5.5, 9.11.x <= 9.11.15, 10.8.x <= 10.8.0, 10.7.x <= 10.7.2, 10.6.x <= 10.6.5 fail to sanitize filenames in the archive extractor which allows authenticated users to write files to arbitrary locations on the filesystem via uploading archives with path traversal sequences in filenames, potentially leading to remote code execution. The vulnerability impacts instances where file uploads and document search by content is enabled (FileSettings.EnableFileAttachments = true and FileSettings.ExtractContent = true). These configuration settings are enabled by default.
Weakness: CWE-427
Which versions are affected by CVE-2025-4981?
18 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250519205859-65aec10162f6 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250519205859-65aec10162f6 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250519205859-65aec10162f6 |
github.com/mattermost/mattermost/server/v8 Go | From 10.5.0 | 10.5.6 |
github.com/mattermost/mattermost/server/v8 Go | From 10.5.0 | 10.5.6 |
github.com/mattermost/mattermost/server/v8 Go | From 10.6.0 | 10.6.6 |
12 more packages
github.com/mattermost/mattermost/server/v8 Go | From 10.6.0 | 10.6.6 |
github.com/mattermost/mattermost/server/v8 Go | From 10.7.0 | 10.7.3 |
github.com/mattermost/mattermost/server/v8 Go | From 10.7.0 | 10.7.3 |
github.com/mattermost/mattermost/server/v8 Go | From 10.8.0 | 10.8.1 |
github.com/mattermost/mattermost/server/v8 Go | From 10.8.0 | 10.8.1 |
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.16 |
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.16 |
github.com/mattermost/mattermost-server Go | All versions | 0.0.0-20250519205859-65aec10162f6, 9.11.16+incompatible, 10.5.6+incompatible, 10.6.6+incompatible, 10.7.3+incompatible, 10.8.1+incompatible |
github.com/mattermost/mattermost-server Go | All versions | 0.0.0-20250519205859-65aec10162f6 |
github.com/mattermost/mattermost-server Go | All versions | 0.0.0-20250519205859-65aec10162f6 |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-4981?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250519205859-65aec10162f6, 10.5.6, 10.6.6 or 10.7.3.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2025-4981 being exploited?
There is no known exploitation of CVE-2025-4981 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
- CVE-2016-11074 Mattermost Server: Insufficient Password-Reset Link Invalidation
Sources
Also known as GHSA-qh58-9v3j-wcjc, GO-2025-3769.