CVE-2025-49810 Thread summarization allows persistent access to channel
Attackers can read private threads via AI posts due to missing access control validation in Mattermost chat platform.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-49810?
CVE-2025-49810 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 21 Aug 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Mattermost versions 10.5.x <= 10.5.8 fail to validate access controls at time of access which allows user to read a thread via AI posts
Weakness: CWE-863
Which versions are affected by CVE-2025-49810?
8 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.9 |
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.9 |
github.com/mattermost/mattermost-server Go | From 10.5.0+incompatible | 10.5.9+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250721095846-c602a4a78e1f |
2 more packages
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250721095846-c602a4a78e1f |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250721095846-c602a4a78e1f |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-49810?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.5.9 or 10.5.9+incompatible.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-49810 being exploited?
There is no known exploitation of CVE-2025-49810 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-pwvr-grqg-7vp2, GO-2025-3903.