CVE-2025-49812 Apache HTTP Server: mod_ssl TLS upgrade attack
Man-in-the-middle attackers can hijack HTTP sessions via TLS upgrade in Apache HTTP Server when SSLEngine optional is enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-49812?
CVE-2025-49812 is a high-severity vulnerability in Apache Http Server, published on 10 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In some mod_ssl configurations on Apache HTTP Server versions through to 2.4.63, an HTTP desynchronisation attack allows a man-in-the-middle attacker to hijack an HTTP session via a TLS upgrade.
Only configurations using "SSLEngine optional" to enable TLS upgrades are affected. Users are recommended to upgrade to version 2.4.64, which removes support for TLS upgrade.
Weakness: CWE-287
Which versions are affected by CVE-2025-49812?
1 open source package ship an affected version, including apache. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache Bitnami | All versions | 2.4.64 |
Linux distribution packages (16)
httpd Red Hat:rhel_aus:7.7::server | All versions | 0:2.4.6-90.el7_7.6 |
httpd-debuginfo Red Hat:rhel_aus:7.7::server | All versions | 0:2.4.6-90.el7_7.6 |
httpd-devel Red Hat:rhel_aus:7.7::server | All versions | 0:2.4.6-90.el7_7.6 |
httpd-manual Red Hat:rhel_aus:7.7::server | All versions | 0:2.4.6-90.el7_7.6 |
httpd-tools Red Hat:rhel_aus:7.7::server | All versions | 0:2.4.6-90.el7_7.6 |
mod_ldap Red Hat:rhel_aus:7.7::server | All versions | 0:2.4.6-90.el7_7.6 |
mod_proxy_html Red Hat:rhel_aus:7.7::server | All versions | 1:2.4.6-90.el7_7.6 |
mod_session Red Hat:rhel_aus:7.7::server | All versions | 0:2.4.6-90.el7_7.6 |
mod_ssl Red Hat:rhel_aus:7.7::server | All versions | 1:2.4.6-90.el7_7.6 |
httpd Red Hat:rhel_els:6 | All versions | 0:2.2.15-71.el6_10.1 |
httpd-debuginfo Red Hat:rhel_els:6 | All versions | 0:2.2.15-71.el6_10.1 |
httpd-devel Red Hat:rhel_els:6 | All versions | 0:2.2.15-71.el6_10.1 |
httpd-manual Red Hat:rhel_els:6 | All versions | 0:2.2.15-71.el6_10.1 |
httpd-tools Red Hat:rhel_els:6 | All versions | 0:2.2.15-71.el6_10.1 |
mod_ssl Red Hat:rhel_els:6 | All versions | 1:2.2.15-71.el6_10.1 |
cyrus-imapd openSUSE:Tumbleweed | All versions | 3.8.6-1.1 |
Products include Apache Http Server.
How do I fix CVE-2025-49812?
Upgrade apache to 2.4.64 or later.
Is CVE-2025-49812 being exploited?
There is no known exploitation of CVE-2025-49812 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Http Server
Sources
Also known as ALPINE-CVE-2025-49812, AZL-65097, AZL-65112, BELL-CVE-2025-49812, BIT-apache-2025-49812, CLSA-2025-1757014860 and 9 more.